Script lockup leads to "not responding" message without content to read or select [caused by Torbutton]

VERIFIED INVALID

Status

()

VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Overseer, Unassigned)

Tracking

({regression})

3.5 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

I have only experienced this while playing NexusWar so far. A script there is implemented to sort the listed entries by name, but takes too long and leads to the not responding message, which then appears without any content (see screenshot).
When clicking the X to close the message, sometimes it appears again with content; then mentioning http://www.nexuswar.com/r/js/jquery/jquery.tablesorter.min.js:2
it IS possible to move the message pane given by FF, but it is NOT possible to click blank into it or press ENTER to get any respond to end it. only X allows to close it.

Reproducible: Always

Steps to Reproduce:
as i have only experienced it in NexusWar this may be hard to reproduce without the required numbers of pets/items there

1. script to sort huge numbers of items maybe inclusive ajax
2. masses of lines/items to sort
3. run both
Actual Results:  
The message which appears does not show any content, nor does it give buttons to select from. only it's headline is shown.

Expected Results:  
it should show a message and give the URL to the not responding script, plus leave two buttons to select to end the script or not.

i am running several plugins, such as AdBlock and NoScript. but both are disabled on NexusWar and both should not lead to this result given.
This is a new problem. it did not appear with earlier versions of FF.

Comment 1

9 years ago
Can you try to reproduce this in Firefox's safe mode?
Assignee: nobody → general
Component: General → JavaScript Engine
Keywords: regression, regressionwindow-wanted
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [Need NexusWar account to reproduce]
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 2

9 years ago
i just tried it in safe mode and it seem to not appear there, so i tested normal FF with all of my installed add-ons one after another and now seem to have pinned down the cause.
apparently the plugin "Torbutton" seems to be involved in the cause, because if it is not active the problem does not appear. stangely Torbutton alone does not lead to the problem. also all the other add-ons without Torbutton do not cause it. but as soon as Torbutton and a random second add-on are active the problem does appear.

Comment 3

9 years ago
Invalid then.  There are two bugs, bug 501859 and bug 501861 that were caused by torbutton and gmail manager.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Whiteboard: [Need NexusWar account to reproduce] → [Caused by Torbutton]
Assignee: general → nobody
Status: RESOLVED → VERIFIED
Component: JavaScript Engine → Extension Compatibility
Keywords: regressionwindow-wanted
Product: Core → Firefox
QA Contact: general → extension.compatibility
Summary: Script lockup leads to "not responding" message without content to read or select → Script lockup leads to "not responding" message without content to read or select [caused by Torbutton]
Whiteboard: [Caused by Torbutton]
Version: 1.9.1 Branch → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.