Closed Bug 503269 Opened 13 years ago Closed 13 years ago

Alt text in right-to-left languages can appear backwards

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: smontagu, Assigned: smontagu)

References

()

Details

(Keywords: rtl)

Attachments

(3 files)

I see this on Flickr when the thumbnails in the "Updates from your contacts" are slow to load.

The issue is the same as bug 370589: the alt text is not part of the DOM so the Bidi enabled flag isn't set in the presContext if there is no other right-to-left text in the page.
Attached patch PatchSplinter Review
Attachment #387626 - Flags: superreview?(roc)
Attachment #387626 - Flags: review?(roc)
Summary: Alt text in right-to-left languages can appears backwards → Alt text in right-to-left languages can appear backwards
Attachment #387626 - Flags: superreview?(roc)
Attachment #387626 - Flags: superreview+
Attachment #387626 - Flags: review?(roc)
Attachment #387626 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/309ccdbc5d9c
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.