Closed Bug 503399 Opened 12 years ago Closed 12 years ago

caret in contentEditable area with text-align:justify doesn't match position

Categories

(Core :: Layout: Text and Fonts, defect)

1.9.1 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: timeless, Assigned: roc)

References

()

Details

Attachments

(2 files)

steps:
1. load test url
2. click into the first <p>
3. press and hold <right-arrow> while watching the caret
4. press <tab>
5. press and hold <right-arrow> while watching the caret

expected results:
caret should always be at the beginning/end of a letter for steps 3 and 5

actual results:
caret in 5 ends up in the middle of the character before where it should be, in the middle of the character before which it should be, and in the middle of the character after the character before which it should be placed.

(originally encountered @docs.google.com with an imported word document.)
Assignee: nobody → roc
useless note: this also happens on Camino (Gecko 1.9) OS X 10.5.7 (x86_64)
OS: Windows 7 → All
Attached patch fixSplinter Review
Attachment #388179 - Flags: review?(smontagu)
Comment on attachment 388179 [details] [diff] [review]
fix

test?
Attachment #388179 - Flags: review?(smontagu) → review+
Do we have a way to get the caret position coordinates?
Huh, probably not :(
Bug 396392 would help testing here.
http://hg.mozilla.org/mozilla-central/rev/f6de98d8c2ff
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Duplicate of this bug: 535195
Attached patch reftest.diffSplinter Review
Pushed the reftest:
http://hg.mozilla.org/mozilla-central/rev/581778538b67
Flags: in-testsuite? → in-testsuite+
Depends on: 564413
Depends on: 566067
Bug 442847, bug 452266 and bug 511620 should be flagged as duplicates of this bug.
Blocks: 442847
Duplicate of this bug: 452266
Duplicate of this bug: 511620
You need to log in before you can comment on or make changes to this bug.