HTML MultiLength attribute type not working as expected

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: decramlet, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.33 Safari/530.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

When a "relative length" (other than "*") is specified for the width of a COL element, relative widths are not calculated for those columns.

Reproducible: Always

Steps to Reproduce:
An HTML example will be attached.

1. Create a table with 5 columns and width 996.
2. Use a COLGROUP and COL elements to specify the column widths as 166, 16.66%, 2*, 1*, and *, respectively.
Actual Results:  
The resulting table had cells 1 and 2 the same width, cells 3 and 4 large enough to hold their respective numbers, and cell 5 filled the remaining width of the table.

Expected Results:  
Cells 1, 2, 4, and 5 should be the same width (allowing for the abilities of the display device), and cell 3 should be twice the width of the other cells.
(Reporter)

Comment 1

9 years ago
Created attachment 387749 [details]
Example HTML
(Reporter)

Comment 2

9 years ago
Missing Repro step:
3. Add one TR, containing 5 TDs, each containing the numbers 1 through 5, respectively.
(Reporter)

Comment 3

9 years ago
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

Just tested with 3.5, in case there had been "standards compliance" improvements. No discernible difference, regarding this issue, from 3.0.11.
Version: unspecified → 3.5 Branch
(Reporter)

Comment 4

9 years ago
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

No reason to think that it would have been addressed, since it's still "unconfirmed", but I felt I should keep it up-to-date. Tested under 3.5.1. No discernible difference, regarding this issue, from 3.0.11.
(Reporter)

Comment 5

9 years ago
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

No reason to think that it would have been addressed, since it's still
"unconfirmed", but I feel I should keep it up-to-date. Tested under 3.5.2. No
discernible difference, regarding this issue, from 3.0.11.
Thanks for the excellent bug report. However, we do not support multilength attributes, as suggested by the HTML specification (<http://www.whatwg.org/html/#margins-and-padding>).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → DOM: Core & HTML
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Resolution: --- → INVALID
Version: 3.5 Branch → Trunk
(Reporter)

Comment 7

7 years ago
I can certainly understand it not working in HTML 5, since the "width" attribute is obsolete there. However, you may notice that the test case is HTML 4.01.

I infer from your response that the more complete answer is: development has moved on the HTML 5, and HTML 4 compliance issues are no longer a consideration.

Thank you for taking a look at it anyway.
The specification I referred to defines how browsers need to handle *all* HTML files, including those that contain HTML4 or XHTML doctypes. (Note that the HTML4 specification has a lot of requirements that can't be implemented without breaking a lot of sites, and so we've never really tried to implement it completely.)

Thanks again for the report.
You need to log in before you can comment on or make changes to this bug.