Closed Bug 503436 Opened 12 years ago Closed 11 years ago

autoconfig UI needs polish.

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: bwinton, Assigned: bwinton)

References

Details

(Keywords: polish)

Attachments

(2 files, 5 obsolete files)

Split off from https://bugzilla.mozilla.org/show_bug.cgi?id=490097#c22

The overflow: auto changes seems reasonable.  Please file a spinoff polish bug
(if there isn't one already).  Candidate changes include:

* make the window resizable too
* it feels like the warning dialog has a very large amount of text on it, to
the point where users are likely to ignore it.  The indentation seems
arbitrary, which adds to the confusion.
* "Get me out of here" seems like misleading text for the warning page button,
because it implies aborting the config process entirely, but actually just
backs up one screen.

All of these seem reasonable to me.
A couple more things, from davida, over IRC:
1) if you hit Next before typing the password, it thinks your password is "Password"
2) the vertical alignment of the last line in the smtp area is off on the mac at least
3) the SSL/TLS - STARTTLS menu is cropped on the mac until you click on it, which is somehow wrong
From Bryan,

in the warning page, try:
4) Single "I understand the risks."
5) Lose the incoming/outgoing settings lines.
6) Maybe don't show any text, and have a "Technical Details" dropdown.

aim for <700 pixels tall.
Just throwing this up for Bryan, to show him how close we can get by removing a little of the padding around the warning dialog.
So, here's what I've got now.  Not perfect, but at least all the text fits in the window.  The settings were getting lost in all the text, though, so I made them bold and yellow to try to bring them out a bit.

OSX-only Patch forthcoming, if you want to try it yourself.
(In reply to comment #0)
> * "Get me out of here" seems misleading.

Fixed.

(In reply to comment #1)
> 1) if you hit Next before typing the password, it thinks your password is
> "Password"

Could not reproduce.

> 2) the vertical alignment of the last line in the smtp area is off on the mac
> at least

Fixed.

> 3) the SSL/TLS - STARTTLS menu is cropped on the mac until you click on it,
> which is somehow wrong

Could not reproduce.

(In reply to comment #2)
> in the warning page, try:
> 4) Single "I understand the risks."

Done.

> * make the window resizable too
> * it feels like the warning dialog has a very large amount of text on it, to
> the point where users are likely to ignore it.  The indentation seems
> arbitrary, which adds to the confusion.
> 5) Lose the incoming/outgoing settings lines.
> 6) Maybe don't show any text, and have a "Technical Details" dropdown.

Still working on these.

Later,
Blake.
Attachment #391333 - Attachment is obsolete: true
I'm still working on the exact text for the headlines and I think we can reuse most of the paragraph form text that we already have in the Technical Details section.

This layout gives 2 sections, 1 for the incoming and 1 for the outgoing server.  We use a single sentence headline under the header, I like the yellow color for this, that tells what the problem is.  All the other text is hidden under the Technical Details expander for each section.

Total size becomes about 8 lines double spaced and I believe we are as clear as possible.  By cutting down on the extra text (collapsed in the tech details) I'm more comfortable that people would actually read it despite the fact that most won't understand it.

Here's the layout

---------

*Incoming Mail Settings*

 pop.example.com does not use encryption

 > Technical Details

*Outgoing Mail Settings*

 smtp.example.com does not use a trusted certificate

 > Technical Details

[ ] I understand the risks

( Change Settings )  ( / Create Account / )
Attached patch Another WIP patch. (obsolete) — Splinter Review
(In reply to comment #6)
> > 1) if you hit Next before typing the password, it thinks your password is
> > "Password"
> Could not reproduce.

Fixed.  (Just for reference, it didn't think my password was "Password", but it looked like it did because the emptytext on the field was the same colour as the disabled field.)

> > 3) the SSL/TLS - STARTTLS menu is cropped on the mac until you click on it,
> > which is somehow wrong
> Could not reproduce.

Fixed, although I'm not really happy with what's happening when we select an outgoing server, and then edit it.  (At first, it didn't re-show the port/security options, now it does, but it still trips a bug later.)

I'll work on that more tomorrow.

Also, the "Create in Advanced Editor" link doesn't work anymore.

Thanks,
Blake.
Attachment #391382 - Attachment is obsolete: true
Attached patch A first cut at the patch. (obsolete) — Splinter Review
(In reply to comment #8)
> I'm not really happy with what's happening when we select an
> outgoing server, and then edit it.  (At first, it didn't re-show the
> port/security options, now it does, but it still trips a bug later.)

Fixed.

> Also, the "Create in Advanced Editor" link doesn't work anymore.

And fixed.

I also did some cleanup to make the files internally consistent, and to make the various versions of accountCreation.css have the same selectors in the same order (admittedly some of them within comments).

Bryan, would you mind if I pushed the changes in comment #7 out to Bug 506290?  They seem to make more sense there, and this patch is getting kind of large already.  ;)

Thanks,
Blake.
Attachment #391521 - Attachment is obsolete: true
Attachment #393409 - Flags: ui-review?(clarkbw)
Attachment #393409 - Flags: review?(philringnalda)
(In reply to comment #9)
> Bryan, would you mind if I pushed the changes in comment #7 out to Bug 506290? 
> They seem to make more sense there, and this patch is getting kind of large
> already.  ;)

That makes a lot of sense to me. :)
Comment on attachment 393409 [details] [diff] [review]
A first cut at the patch.

For the outgoing server I think we should be keeping the probed server value in the menulist as an option.  Right now if you choose another existing server there is no way to get back to the probed value.  Similarly for the editing the host name on the probed value we should be keeping a copy of the original probed value as a choice so the user can always get back to it.

Here's how I think we want our menu option to look after the probing has finished:

[ probed server| v ]
.------------------.
| Default Server 1 |
| Default Server 2 |
'------------------'


Then if you choose a default server we want to retain the original probed value as another choice.

[ default server 1| v ]
.------------------.
| probed server    |
|------------------|
| Default Server 1 |
| Default Server 2 |
'------------------'

Here's how our menu looks after the person has customized any of the values; host, port, security.

[ custom server | v ]
.------------------.
| probed server    |
|------------------|
| Default Server 1 |
| Default Server 2 |
'------------------'

And here's how our menu looks if the person had customized the values but then chose the probed values instead.

[ probed server | v ]
.------------------.
| Custom Server    |
| probed server    |
|------------------|
| Default Server 1 |
| Default Server 2 |
'------------------'

"Custom Server" probably isn't the best text here but something along those lines to indicate that the person had manually edited settings and we kept them.

Perhaps to reduce complexity we could just always show the probed value, separator, existing servers in the menu and then only change the menu when there is a custom server to add.

It would be nice if the menulist item was a bit wider to accommodate the text better.  I tried with flex=1 on it but that's much too large.  Ideally it might be the same width as the width of all the other options below it.

This is working a lot better now.
Attachment #393409 - Flags: ui-review?(clarkbw) → ui-review-
Blocks: 506290
This is the same as the previous version, except that the outgoing server dropdown is disabled until you hit the edit button, and the port and security textfields revert to their previous values when you select a menu option.

Thanks,
Blake.
Attachment #393409 - Attachment is obsolete: true
Attachment #396438 - Flags: ui-review?(clarkbw)
Attachment #396438 - Flags: review?(philringnalda)
Attachment #393409 - Flags: review?(philringnalda)
Comment on attachment 396438 [details] [diff] [review]
The second cut at the patch
[Checkin: Comment 14]

ok, just tested this out and looks like it works great now.  Thanks!
Attachment #396438 - Flags: ui-review?(clarkbw) → ui-review+
Attachment #396438 - Flags: superreview?(bienvenu)
Attachment #396438 - Flags: review?(philringnalda)
Attachment #396438 - Flags: review+
Attachment #396438 - Flags: superreview?(bienvenu) → superreview+
Keywords: checkin-needed
Comment on attachment 396438 [details] [diff] [review]
The second cut at the patch
[Checkin: Comment 14]


http://hg.mozilla.org/comm-central/rev/189aba5c6bc5
Attachment #396438 - Attachment description: The second cut at the patch. → The second cut at the patch [Checkin: Comment 14]
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.