If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 3.5 hangs for ~60sec while rendering IMDb MyMovies page with >1500 checkboxes

RESOLVED DUPLICATE of bug 477564

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 477564
8 years ago
8 years ago

People

(Reporter: Attila B, Unassigned)

Tracking

({hang})

3.5 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Firefox 3.5 is not responding for about 60 seconds while rendering the page. The 3.0.x version renders this page in 1-2 sec. So v3.5 is 20-40 times slower, on this particular page. Speed is one problem, but the real problem is that the process is not responding to mouse and keyboard events. 

My Movies (all) page contains ~1600 titles. Rendering a page with ~700 titles takes "only" 10 seconds and the same not responding issue. 

See Mozilla Reporter:
 - RMO12472475245711
 - RMO12462161785463
 - RMO12464359507899

There were no problems when I made one of my categories with ~700 titles public, and opened the url without logon. The difference between the w and w/o logged on pages is that the Votes column is empty if the user is not logged on. I think maybe the rendering of the cells of the Votes column is the cause of the problem.

I'm going to try to reproduce it while disabling all add-ons in safe mode.

Reproducible: Always

Steps to Reproduce:
1. Open an IMDb MyMovies page with more than 1000 titles, logged on (Votes column must not be empty)

Actual Results:  
Browser hangs and is not responding to events (keyboard, mouse, ...) for minutes.

Expected Results:  
Not freezing for minutes.

I can provide the list of add-ons, if the hanging problem doesn't occur in safe-mode when all add-ons are disabled.

I'm going to attach the saved page in zip format (MyMovies.htm and MyMovies_files folder).
(Reporter)

Updated

8 years ago
Keywords: hang
Summary: Firefox 3.5 is not responding (hangs) for ~60 seconds while rendering the page → Firefox 3.5 hangs for ~60sec while rendering IMDb MyMovies page with >1500 titles
(Reporter)

Comment 1

8 years ago
The problem also occurs in Vista, see RMO12462161785463 - OS/CPU: Windows NT 6.0
(Reporter)

Comment 2

8 years ago
The non respondig issue happens even if all add-ons are disabled in safe-mode
(Reporter)

Comment 3

8 years ago
Created attachment 387936 [details]
HTML testcase to reproduce the problem
(Reporter)

Updated

8 years ago
OS: Windows XP → All
Version: unspecified → 3.5 Branch
(Reporter)

Comment 4

8 years ago
The difference between the w and w/l log in versions is that the Votes column contains ~1600 cells with fields like this:
<input type="checkbox" name="e" value="79970368:0114924" >
(Reporter)

Comment 5

8 years ago
This not responding and very bad performance issue only occurs if the user is logged in and the first column (not the Votes column) contains all the checkboxes.
It seems that the root cause is the rendering of the more than 1500 <input type="checkbox" name="e" value="0000000:000000"> tags.
(Reporter)

Updated

8 years ago
Summary: Firefox 3.5 hangs for ~60sec while rendering IMDb MyMovies page with >1500 titles → Firefox 3.5 hangs for ~60sec while rendering IMDb MyMovies page with >1500 checkboxes
(Reporter)

Updated

8 years ago
Flags: blocking-firefox3.6?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477564
Flags: blocking-firefox3.6?
You need to log in before you can comment on or make changes to this bug.