If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Icons missing for developer tags

VERIFIED FIXED in 5.0.7

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: fcp, Assigned: clouserw)

Tracking

unspecified
5.0.7

Details

(URL)

(Reporter)

Description

8 years ago
Bug 501203 states that it is VERIFIED FIXED, but I still do not see icons for developer tags in Firefox 3.5.

The stylesheet at
https://preview.addons.mozilla.org/css/amo2009/style.min.css?29592
contains
> .addon-tags .developertag .tagitem{
> padding-left:20px;
> background-image:url(../../img/amo2009/icons/icons.png);
> background-repeat:no-repeat;
> background-position:0 -700px;
> background-image:url(../../img/amo2009/icons/tag_green.png);
> }
where the background-position and one of the two background-image's are incorrect (more precisely, not yet correct).

This apparently comes from
http://viewvc.svn.mozilla.org/vc/addons/branches/webmocha/site/app/webroot/css/amo2009/main-mozilla.css?revision=28285&view=markup#l1634
but in main-mozilla.css these incorrect lines are effectively commented out.  I do not know how style.min.css?29592 is generated or why it contains these lines.
(Reporter)

Comment 1

8 years ago
I was looking at a wrong branch in comment #0.  This is not fixed on preview.addons.mozilla.org because of the following.
http://viewvc.svn.mozilla.org/vc/addons/trunk/site/app/webroot/css/amo2009/main-mozilla.css?revision=29604&view=markup#l2195
> .addon-tags .developertag .tagitem {
>     padding-left: 20px;
>     background-image: url(../../img/amo2009/icons/icons.png);
>     background-repeat: no-repeat;
>     background-position: 0px -700px;
>     background-image: url(../../img/amo2009/icons/tag_green.png);
> } 

I do not know what the “webmocha” branch on the Subversion repository is for.  Depending on that, this may not be a problem.
(Assignee)

Comment 2

8 years ago
Thanks for the heads up, not sure what happened here.  This is fixed in r29607

For the record, the webmocha branch was temporary and will be going away soon.  It's no longer used for anything.
Assignee: nobody → clouserw
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.0.7
(Reporter)

Comment 3

8 years ago
Thanks, Wil, for fixing it and for explaining the webmocha branch.  Now it shows the icon for developer tags perfectly.
Verified FIXED via fcp's comment 3, and my own testing on https://preview.addons.mozilla.org/en-US/firefox/addon/12466; fcp, I can give you permissions to file bugs as NEW and confirm/resolve/verify them -- just let me know, thanks!
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.