Prevent webpages from stealing focus on new window if you are typing in the address bar or search bar

RESOLVED DUPLICATE of bug 125282

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED DUPLICATE of bug 125282
9 years ago
9 years ago

People

(Reporter: asdfqwertyuiop1, Unassigned)

Tracking

3.5 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

I have http://www.google.com set as my home page. If I open a new window, sometimes my network is a bit slow, and it takes a few seconds to load google.com. I press Ctrl-L and start typing away to where I want to go, but when Google loads, its search box steals focus. Thus, I'll probably run into a variant of the following scenario:

I typed "nyti" in the location bar, Google steals focus, and I continue typing without stopping...I type "mes" and hit ctrl-enter. I will end up searching Google for "mes". :(

Reproducible: Always

Steps to Reproduce:
1. Set http://www.google.com as your homepage.
2. Open a new window.
3. Before Google loads, put the cursor on the location bar or put the cursor on the the search bar and start typing.
4. Wait for Google to load
Actual Results:  
Google's search box steals focus. This often interrupts my typing, and is quite annoying.

Expected Results:  
I can continue to type away on the location bar without interference.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 125282
You need to log in before you can comment on or make changes to this bug.