flash wmode transparent handling fails to show flash components and fullscreen mode

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Gideon Visbeen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1) Gecko/20090624 Firefox/3.5

In the previous version of firefox, the transparent handling for flash showed no problems, default flash components like ComboBox and showing flash fullscreen worked.

A example of the combo problem is show here:
http://www.orakels.org/php/?m=wo_tarot_online

If your remove the wmode or set it to window it works correct again, see:
http://www.orakels.com/php/?m=wo_tonline

Reproducible: Always

Steps to Reproduce:
1. Open the page 
2.
3.
Actual Results:  
The page with the flash is show, but the combobox component in the flash are missing when the wmode is set to transparent.

Expected Results:  
Show the combobox in flash in wmode transparent, and if chosen the flash fullscreen mode should be supported in wmode transparent

this worked properly in the previous version of firefox
Can you point out what button exactly doesn't work?
(Reporter)

Comment 2

9 years ago
the flash is supposed to show 3 comboboxes on the right upper corner of the flash app. The comboboxes show properly if wmode=window but the don't show if wmode=transparent. You can see the difference using the two links in the original post of this bug.

The problem with fullscreen in wmode transparentcan be seen at: (don't forget to press the button fullscreen)
http://www.orakels.org/php/?m=wo_chillout_zone

here is the same flash but with wmode at window wich does work:
http://www.orakels.com/php/?m=wo_chillout
Tested with Firefox 3.5 on Windows Vista, Shockwave Flash Version: 10.0.22.87 :

On this address http://www.orakels.org/php/?m=wo_tarot_online I see three blue selectboxes "Het levenskruis" etc. but no fullscreen button.
On this address http://www.orakels.com/php/?m=wo_tonline exactly the same.

On this address http://www.orakels.org/php/?m=wo_chillout_zone I see no blue dropdown menus but I do see a (working) fullscreen button.
And the same goes for http://www.orakels.com/php/?m=wo_chillout .
(Reporter)

Comment 4

9 years ago
Perhaps posting 2 different bugs is confusing. I've rebuild my site to show the difference for the blue dropdown menu's

the link below shows the blue dropdown menus:
http://www.orakels.org/php/?m=wo_tarot_online&wmode=window

the link below fails to show the blue dropdown menus:
http://www.orakels.org/php/?m=wo_tarot_online&wmode=transparent

I've tested this on 2 different computers both using firefox 3.5 on Windows XP SP3 and the bug is repeatable (at least here)

Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1) Gecko/20090624 Firefox/3.5
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Nope; http://www.orakels.org/php/?m=wo_tarot_online&wmode=transparent is showing the selectboxes.

You have already the latest Flash version?
Please also try safe-mode to exclude extension problems:
http://support.mozilla.com/en-US/kb/Safe+Mode
Or a new profile:
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
If the problem persists, try reinstalling Firefox in a different folder.
(Reporter)

Comment 6

9 years ago
installing flashplayer v10 corrected the problem, thanx for your patience and the solution (should have tried that first, silly me *shame shame*)


Kind regards, Gideon
Resolving Invalid (= not a bug in Firefox) per comment 6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.