email deletion when using arrow keys with an open email

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: fred_g_bdx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.22 (20090605)

While opening an email (x2 click on it), pressing on a single arrow key on the keyboard (up/down/right/left) is enough to delete the current message, sending it to the trash. This is done without any warning.
This looks like beautiful bug.

This bug is systematic under windows.
Under linux everything is fine : use of arrows just scroll in the message. No deletion at all.


Reproducible: Always

Steps to Reproduce:
1. go to an email folder in TB
2. list of email is appearing
3. 2x click on an email, the email window is open showing the messages and all usual standard information (so far so good)
4. Pressing any single arrow key on the keyboard is making email to be directly deleted and send to trash !!!!!
5.Automatically next email is open ... ready to be deleted is pressing any arrow on the keyboard
Actual Results:  
Email are automatically deleted without any report/warning/information by just pressing an arrow key (donw/up/right/left)

Expected Results:  
Use of arrows on keyboard when reading an open email should not delete the email! Just scrolling in the messages!
IMAP? Or local mail folder(POP3, "Local Folders")?
Can you reproduce problem with -safe-mode of Tb or new profile?
Do you use external software relates to keyboard(e.g. changes key assignment)?
Do you use retention policy of Keep/"only unread messages"? (Folder Properties)
(Reporter)

Comment 2

9 years ago
POP3 account / local folder.

Not able to reproduce it in safe mode. Able to reproduce it in Std mode.

No specific software related to keyboard assignment!

No retention policy used. Messages shoudl stay in! I did not know this option.
(Reporter)

Comment 3

9 years ago
Ok I did more investigation:
the bug is coming from MoreFunctionsForAddressBook or its integration on thunderbird for windows.

desabling the addon solve the issue.

I still confirm that under linux, same version, with MoreFunctionsForAddressBook 0.5.5.1, i do not have the bug.

Would be nice to have a confirmation on another machine but i do not have another Xp system in the neighbourghood.
Per comment 3 resolving invalid - if it is an extension causing a problem then we can't fix it here, please contact the extension author directly.

If this is a problem with no extensions enabled, please feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 5

9 years ago
This is probably a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=408480 , that involves Lightning , please see my comment at #9
You need to log in before you can comment on or make changes to this bug.