Auto-clear filters when results go from 1 to 0

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
--
enhancement
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
Steps to reproduce:

1. Use filters to look for a specific add-on that, say, you had a discussion reply about, and now want to continue reviewing.
2. Filters return just 1 result (you typed the add-on name, and it was fairly unique)
3. You review the add-on.
4. After reviewing, AMO redirects you back to the queue.

Actual results:
The queue now lists 0 add-ons, because you reviewed the one you were looking for. Now I have to manually clear the filter and wait for the page to reload (which is pretty slow anyway) before I have any kind of useful information/situation again.

Expected results:
I was looking for this 1 add-on, and now it's gone, so I think it would be good to auto-reset the filter now that I've dealt with that add-on. I'm not sure if this is hard to do technically; if so, then it may not be worth it... (and I won't be offended if you WONTFIX) but I've run into this situation a few times, and it's irksome. :-)
It's a valid case, but I don't think it happens enough (and the current results aren't unexpected) to justify the time to change it.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.