Last Comment Bug 503718 - Unwanted horizontal scrollbars on Google Reader
: Unwanted horizontal scrollbars on Google Reader
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: x86 All
: P2 normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.google.com/reader/
: 503909 (view as bug list)
Depends on:
Blocks: 475968 476927
  Show dependency treegraph
 
Reported: 2009-07-11 18:37 PDT by Sylvain Pasche
Modified: 2009-09-02 10:48 PDT (History)
12 users (show)
roc: blocking1.9.2+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta1-fixed


Attachments
testcase, partly reduced (798 bytes, text/html)
2009-07-11 18:37 PDT, Sylvain Pasche
no flags Details
simplified test case (711 bytes, text/html)
2009-07-13 02:36 PDT, Jonathan Kew (:jfkthame)
no flags Details

Description Sylvain Pasche 2009-07-11 18:37:46 PDT
Created attachment 388113 [details]
testcase, partly reduced

Appears to be a regression from bug 475968. Horizontal scrollbars are visible below the text on every feed item.

Attached testcase links to the Google CSS, it would certainly appreciate some more reduction.
Comment 1 Sylvain Pasche 2009-07-11 18:41:04 PDT
By the way, it happens with ClearType turned on or off.
Comment 2 Jonathan Kew (:jfkthame) 2009-07-12 01:34:23 PDT
It happens with or without ClearType turned on because the underlying issue exists even with "standard" antialiasing -- glyphs may paint pixels just beyond their nominal bounds -- the discussion generally centers on CT because that's when it becomes really noticeable. Without CT, the potential drawing problems (clipping, artifacts) are so minor that they're unlikely to be noticed and reported.

And the unwanted scrollbars appear on OS X as well, due to bug 476927 which was the Mac equivalent to the Windows ClearType issue.
Comment 3 Jonathan Kew (:jfkthame) 2009-07-12 01:36:12 PDT
Marked as "all" platforms although I assume it's really just Windows and Mac; we don't seem to have an option for selecting several separate choices.
Comment 4 Jonathan Kew (:jfkthame) 2009-07-12 01:47:17 PDT
I think the right way to resolve this (and resolve or pre-empt other similar issues*) would be to stop overloading the concept of the frame's "overflow area". The trouble is that "visual overflow", needed for correct painting/invalidation, may be different from "structural overflow", which is what determines the appearance of scrollbars, and relates to the CSS overflow property.

Although it's conceptually simple, it means checking each place in layout where overflow is set, used, or propagated up the tree, to determine which kind(s) of overflow it should be considering. Roc, WDYT?

(*) Just as I was typing this comment, I saw a horizontal scrollbar appear momentarily at the bottom of the input area, as the cursor reached the right edge of one line. Probably a manifestation of the same problem.
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-07-12 15:29:30 PDT
You're right. I had Karl lined up to do that but he's been busy with other bugs.

Probably we should back out bug 475986 and bug 476927 until that's done.
Comment 6 Jonathan Kew (:jfkthame) 2009-07-13 02:36:57 PDT
Created attachment 388202 [details]
simplified test case

A simplified test case with three versions of a Google Reader-like <div>.

In testing on Mac OS X and Windows, Firefox 3.5 shows no scrollbar on the first example, but the second and third (using a larger font size, or setting the optimizeLegibility hint) have scrollbars.

Current Minefield trunk build shows scrollbars on all three versions of the <div>. The patches from bug 475986 and bug 476927 just make it likely that the unwanted scrollbar will appear in more circumstances, but the underlying problem was already present.

(BTW, Safari 4 does not show a scrollbar in any of these test cases. I think that's more correct.)
Comment 7 Samuel Sidler (old account; do not CC) 2009-07-13 11:37:37 PDT
*** Bug 503909 has been marked as a duplicate of this bug. ***
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-07-28 03:20:48 PDT
Fixed by backouts.
Comment 9 David Baron :dbaron: ⌚️UTC-10 2009-07-30 14:26:36 PDT
I think the references to bug 475986 above should all reference bug 475968 instead.
Comment 10 Tanner M. Young [:tmyoung] 2009-08-07 22:18:35 PDT
There is one one place where scrollbars still appear in Google Reader.

If you click on "People you follow" it places a scrollbar under their name when you click their link.  I don't know if this is worth reopening the bug, but I thought I would mention it before we Verify it as Fixed.
Comment 11 Mike Beltzner [:beltzner, not reading bugmail] 2009-08-25 10:39:37 PDT
Mass change: adding fixed1.9.2 keyword

(This bug was identified as a mozilla1.9.2 blocker which was fixed before the mozilla-1.9.2 repository was branched (August 13th, 2009) as per this query: http://is.gd/2ydcb - if this bug is not actually fixed on mozilla1.9.2, please remove the keyword. Apologies for the bugspam)

Note You need to log in before you can comment on or make changes to this bug.