Closed Bug 503730 Opened 12 years ago Closed 12 years ago

[autoconfig] Remove unused customfields strings, XUL, and code

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 490097
Thunderbird 3.0b4

People

(Reporter: philor, Assigned: philor)

References

Details

Attachments

(1 file)

Attached patch rmSplinter Review
Support for actually showing customfields UI in the autoconfig wizard didn't pass ui-r, so it's never shown, but it landed with the strings and XUL and some code still around, on the theory that someone would file a bug to fix it up and... fix it up.

That never happened, and now that we're getting close to finally moving the strings over to locales, it's time to remove the confusing leftovers, so it can land fresh and whole if anyone does ever fix it.
Attachment #388117 - Flags: review?(bienvenu)
Target Milestone: --- → Thunderbird 3.0b4
Do not remove my code! I plan to resurrect it.

I Byran did agree to it in Barcelona, I don't know why he rejected the patch. The UI discussion is not finished.

This is needed for many ISPs.
These unused strings and the unused strings from enableURLs were the primary reason why I insisted on landing the strings in content back in April, where we left them for so long that now we're going to ship a beta with the whole feature unlocalized.

It's nice that you plan to resurrect it, and if you ever do, you'll be able to use -R on the patch here to give yourself a starting point, but your desire to resurrect it, separate from any actual activity like even filing a bug much less attaching a patch, does not mean that we are somehow required to force localizers to translate a bunch of strings with no way to see the result and no way of knowing whether or not those strings will actually be used in any final result, nor does it mean that we are required to constantly remember that anything in autoconfig which looks unused might be unused, or might be part of something that landed disabled and might or might not be repaired sometime, or not, maybe.

If you want this stuff to exist, the way to make that happen is to file a bug, explaining *how* and *why* it is needed for many ISPs, rather than just repeating that claim over and over, with a config file which actually uses it, and either a patch that moves it to a separate window like Bryan's explanation of why he gave it ui-r said it should, or an explanation of why that won't work and a patch that reenables showing it, so that he can see why it needs to be in the main window.
Phil is right. Unused strings are a burden for localizers and should not be (intentionally) landed in comm-central.
Whiteboard: [needs review bienvenu]
Attachment #388117 - Flags: review?(bienvenu) → review+
Whiteboard: [needs review bienvenu] → [needs landing post-freeze]
Looks like Blake picked this up while I was out.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: [needs landing post-freeze]
Duplicate of bug: 490097
You need to log in before you can comment on or make changes to this bug.