If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to log in to Dell Powerconnect 2708 switch with Private Browsing turned off

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: jrandomentity, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-1])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

I have a number of Dell Powerconnect switches which use an HTTP GUI for administration.  What I've found is that if Private Browsing is turned off, it's impossible to log in to them - entering the correct username and password just results in an infinite loop of being given the login page.

Reproducible: Always

Steps to Reproduce:
1. Make sure Private Browsing is turned OFF in Firefox and that the switch is configured to allow HTTP admnstration.
2. Attempt to log in to the switch using known-good credentials.  Note that you're stuck in an infinite loop of being returned to the login page.
3. Turn Private Browsing on.
4. Try logging in to the switch again.  Note that this time it actually worked.
Actual Results:  
Infinite loop of being stuck at the switch's login page.

Expected Results:  
Should have been able to log directly into the switch's administrative GUI.

This bug may also affect the Powerconnect 2716 and 2724 switches as they're the same family, although I don't have any available to test with at the moment.

Checked for this behaviour under Firefox 3.5 on XP Pro (x86): does not appear to happen.
Does this happen if you try to login the first time after a firefox startup ?
Does it work if you create an additional test profile ?
http://kb.mozillazine.org/Profile_Manager
(Reporter)

Comment 2

8 years ago
It can happen inconsistently after initial startup - sometimes it'll work, other times it won't.  I am getting the same result with the test profile, however.
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.