External links overwrite current tab (should use new tab/window)

RESOLVED DUPLICATE of bug 477746

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 477746
9 years ago
4 years ago

People

(Reporter: paul, Unassigned)

Tracking

3.5 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

When clicking on external links (e.g. in another program or a .url file) the link is opened in the current tab, overwriting it. Previously (FF3.0) the link would be opened in either a new tab or a new window depending on the user's preferences.

Reproducible: Always

Steps to Reproduce:
1.Click a link in an external program or a .url file.

Actual Results:  
Current tab overwritten with new URL.

Expected Results:  
New URL opened in new tab or window.

This breaks the multi-document UI. Every other program which supports multiple documents under one interface opens new documents in a new window or tab. 

Overwriting the currently open document and potentially destroying user data if, for example, data had been entered into a form but not submitted, is never the correct behaviour. There are many other examples of data loss:

- User is interacting with e.g. a Flash app that holds data which is lost when the page is navigated away from

- User is uploading a file, which is cancelled by navigating away from the page

- User cannot go back to results of a HTTP POST without re-submitting the POST data, which in some cases is not possible (e.g. for security reasons)

For this reason I marked the bug as "critical", user data should never be destroyed.

It also breaks the Firefox tab UI by not using tabs. The "Open new windows in a new tab instead" preference is also broken, as clicking an external URL or double clicking a .url file would normally open a new window which would be re-directed to a tab, but in this case neither happens.
(Reporter)

Comment 1

9 years ago
I should add that there is a work around for this, but it's not very nice:

1. Open an Explorer window (e.g. double click on My Comptuer)
2. Select Tools->Folder Options...
3. Select the "File Types" tab
4. Select "(NONE) URL: Hypertext Transfer Protocol"
5. Click "Advanced..."
6. Select "open" and click "Edit..."
7. Untick "Use DDE"
8. Change the "Application used to perform action" from ' "C:\Program Files\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1" ' to ' "C:\Program Files\Mozilla Firefox\firefox.exe" -requestPending -osint -new-tab "%1" ' (note the double quote marks)

Save your changes and repeat for "(NONE) URL: Hypertext Transfer Protocol with Privacy" and "(NONE) Firefox URL".

No idea how to fix it for Linux/Mac.
(Reporter)

Comment 2

9 years ago
One other thing, data can be lost with no user interaction, if another program decided to open a URL of it's own accord. An example of this would be a program which opens it's web site when it needs an update, or when the user is trying to uninstall it, or as part of a shareware "nag" system.

Comment 3

9 years ago
This is not the default behavior please check if Firefox's safe mode or a new
profile changes this http://support.mozilla.com/en-US/kb/Basic+Troubleshooting
This works for me. Please try safe mode or a new profile as asked in comment #3

Updated

9 years ago
Severity: critical → major
Component: Shell Integration → Tabbed Browser
QA Contact: shell.integration → tabbed.browser
Version: unspecified → 3.5 Branch
(Reporter)

Comment 5

9 years ago
Tried safe mode, can confirm the same behaviour.

I also tried FF3.5 on a Windows 7 and a Windows Vista SP2 machine at work, same behaviour.

Have you guys tried safe mode?

Also, the fix I posted does not lost, when FF is restarted it thinks it is no longer the default browser. Setting it back to the default browser clears the fix.
How about a new profile?
(Reporter)

Comment 7

9 years ago
A new profile fixed things, but broke other stuff.

It appears that the behaviour of browser.link.open_newwindow and browser.link.open_newwindow.restriction have been changed in FF 3.5.

It is now impossible to have things set up the way I had previously:

1. Links in web pages that open in new windows are redirected to open in the current tab

2. Links in external programs open in a new tab

It seems that now it's all-or-nothing, either you trash the current tab all the time or have a new tab all the time.

Note to devs: Please don't break established behaviour of about:config items, add a new preference instead.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477746
You need to log in before you can comment on or make changes to this bug.