Quick search does not remember selection on restart

RESOLVED FIXED in Thunderbird 3.0b3

Status

--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Usul, Assigned: asuth)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b3
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
STR:
In quick search select "subject or from".
Restart TB

Quick search should be on "subject or from" but is on subject
(Reporter)

Updated

9 years ago
Duplicate of this bug: 503834

Comment 2

9 years ago
Isn't it a regression?
Keywords: regression
(Reporter)

Updated

9 years ago
Blocks: 497199

Comment 3

9 years ago
I think this is a really bad regression, in that it appears that quick search is broken, when I search for a particular sender, or that I've lost mail -  i.e., I'm so used to quick search terms being sticky that I don't notice restart has reset the terms.

I'd really like this fixed for b3.
Flags: blocking-thunderbird3?
This definitely blocks Tb3, and it should probably block 3.0b3 as well.
Group: mozilla-confidential
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b3
Group: mozilla-confidential
Keywords: regressionwindow-wanted
Assignee: nobody → bugmail
Whiteboard: [needs patch, reviews]
Bumping to major based on it being a "really bad regression".
Severity: normal → major
With -r f6e6df3e2f7d (the changeset before bug 474701), it correctly persisted four of the six choices, coming back from "To or CC" as "From" and from "Subject, To or CC" as "Subject or From" (which I don't even see filed, making me question whether this is really an end-of-the-world regression).
Keywords: regressionwindow-wanted
(In reply to comment #6)
> (which I don't even see filed, making
> me question whether this is really an end-of-the-world regression).

I think the significant issue is switching from "Subject or From" to "Subject" - it looses context unexpectedly and I'm guessing it is potentially the default for most people.

Comment 8

9 years ago
(In reply to comment #6)
> With -r f6e6df3e2f7d (the changeset before bug 474701), it correctly persisted
> four of the six choices, coming back from "To or CC" as "From" and from
> "Subject, To or CC" as "Subject or From" (which I don't even see filed, making
> me question whether this is really an end-of-the-world regression).

Didn't it depend on context ("To or CC" for Sent mail vs. "From" for Inbox)?
(Assignee)

Comment 9

9 years ago
(In reply to comment #6)
> With -r f6e6df3e2f7d (the changeset before bug 474701), it correctly persisted
> four of the six choices, coming back from "To or CC" as "From" and from
> "Subject, To or CC" as "Subject or From" (which I don't even see filed, making
> me question whether this is really an end-of-the-world regression).

Rimas is right (comment #8).  onSearchFolderTypeChanged is doing the mapping on purpose and has always done the mapping on purpose.

http://mxr.mozilla.org/comm-central/source/mail/base/content/searchBar.js#262
Status: NEW → ASSIGNED
(Assignee)

Comment 10

9 years ago
Created attachment 388385 [details] [diff] [review]
v1 clean up the search widget constructor, make regression go away?

This simplifies the constructor logic in the quick-search XBL widget.  Said widget and its exo-logic in searchBar.js still have non-trivial issues.

This improves things in my manual testing, but does not introduce a unit test.  A real unit test would uncover all the other horrible issues that we don't have time to fix in the next day.
Attachment #388385 - Flags: review?(philringnalda)
Comment on attachment 388385 [details] [diff] [review]
v1 clean up the search widget constructor, make regression go away?

Discretion being the better part of hotdog factory tours, I didn't look too closely beyond "yep, that does work," but working is a good thing. A rather unorthodox time and place to change the default item, but after all it *is* a better choice.
Attachment #388385 - Flags: review?(philringnalda) → review+
Whiteboard: [needs patch, reviews] → [has patch, review; needs checkin]
Where by "change the default item" I apparently meant "and thanks for catching that the XUL wants 'value="2"' but would be defeated by a persistence problem."
Duplicate of this bug: 504154
(Assignee)

Comment 14

9 years ago
pushed: http://hg.mozilla.org/comm-central/rev/916b3ed62ca7
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [has patch, review; needs checkin]
Duplicate of this bug: 504470
OS: Mac OS X → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.