Closed Bug 503871 Opened 12 years ago Closed 12 years ago

Copy AB account to mailing list of another AB destroy some data

Categories

(Thunderbird :: Address Book, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Aureliano, Unassigned)

References

Details

(Keywords: dataloss, regression)

STR:

1. Using 2 address book AB1 and AB2
2. in AB2 there is a mailing list named ML1:
3. add an account (that has firstname, surname, displayname and email) from AB1 to ML1;
4. account is copyed but after close ML1 window it appair twice in ML2 pane.
5. moving (selecting) to AB1 and re-move to ML1 node, the new account copied is displayed only one time (right), but double click on it show a window that haven't firstname and surname.

The issue is still present after TB restart.
Summary: Copy account to mailing list of another destroy some data → Copy AB account to mailing list of another AB destroy some data
In addition, there is no expand widget on AB name to give list of mailing list names. I wonder if this isn't partly a regression of some core change
Keywords: regression
Thanks Aureliano. can you nail the regression range to a 1 day period?
Aureliano, also, is step 5 really dataloss, or just temporary?  if real, please add dataloss to keywords. But if not, please remove "destroy" from summary.
Add dataloss keyword.

Wayne I cannot point to an exact datetime, but using  bug #494565, I can say that this happens after >=2009-07-12 or a few days before because first I have a differen behavior.
Keywords: dataloss
I try to reproduce this bug to find regression date

Step 1: I create 2 Address Books AB1 and AB2 => OK
Step 2: I create in AB2 a mailing list called ML1 => OK
Step 2 bis: I create in AB1 a contact with firstname / surname / displayname and email => OK
Step 3: I add (drag & drop) this just created AB1 contact to ML1 which is in AB2 => OK
Step 4: then what is ML2 ? does it belong to AB1 or AB2 ?
>4. account is copyed but after close ML1 window it appair twice in ML2 pane.

sorry, should be

4. account is copyed but after close ML1 window it appair twice in AB2 pane.
I tried to reproduce this bug to find regression date

Step 1: I create 2 Address Books AB1 and AB2
Step 2: I create in AB2 a mailing list called ML1
Step 2 bis: I create in AB1 a contact with firstname / surname / displayname
and email
Step 3: I add (drag & drop) this just created AB1 contact to ML1 which is in
AB2
Step 4: Select AB1 then select ML1 in AB2.
Step 5: Double click on new contact in ML1 to check if there is firstname and lastname ?

Aureliano: Did I reproduce correctly your test scenario?

If yes, I checked with:

=> Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4 ID:20090915181920
Contact in AB2 has both first and lastname

=> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050715 Thunderbird/3.0a1 ID:2008050715
Contact in AB2 has both first and lastname

=> version 2.0.0.23 (20090812)
Contact in AB2 has both first and lastname

I can not reproduce this bug
Confirmed now is WFM here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090926 Lightning/1.0pre Shredder/3.0pre ID:20090926031214

Thanks cantalou
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.