Closed Bug 503910 Opened 12 years ago Closed 12 years ago

hg web interface shows no changes for bug 263683 mochitest checkin

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 503869

People

(Reporter: dholbert, Unassigned)

References

()

Details

STEPS TO REPRODUCE:
 1) Load http://hg.mozilla.org/mozilla-central/rev/99cf4f9414d7
    or http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4fdf4d62e797

ACTUAL RESULTS:
 No changes displayed -- looks like an empty changeset.

EXPECTED RESULTS:
 Show the changes. (2 deleted reftest files, 1 added mochitest file, 2 modified test-manifests)

This seems like a bug in the mercurial web interface -- probably needs a bug in Mercurial's bug tracker, but I'm also filing it here, to have a place within Mozilla for tracking the status of this issue.

NOTE: If you click the "raw" link at the top of the HG web interface, it correctly shows the changes. (in raw diff form)
What is special on this changeset that there is no diff shown? Interesting.
If I try firing up a local HG web server, it displays the change just fine.
That is, I run "hg serve" on the command line (from within my source dir), and visit:
  http://localhost:8000/rev/99cf4f9414d7
then I get expected behavior.

I'm running hg version 1.1.2.

So, perhaps this is related to an old version of HG that's running on the hg.mozilla.org server?  Or maybe it's due to the specific "theming" that we use?
dholbert: hg.m.o should be running something newer than what you've got by now. It looks like it's probably due to the gitweb-mozilla template probably missing another string (since it crashes while generating the content).
Reproduced on my local setup. This is the same as bug 503869. Resolving as duplicate, adding patch to that bug.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503869
Looks good now. Verified dupe.
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.