[MLK] Leaking an AtomImpl

VERIFIED DUPLICATE of bug 44626

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED DUPLICATE of bug 44626
18 years ago
14 years ago

People

(Reporter: Patrick C. Beard, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The above URL points to the line:

kDefaultServerAtom = NS_NewAtom("DefaultServer");

Given that kDefaultServerAtom is an nsCOMPtr, this is a leak, because you are 
AddRefing twice. This is such a common error, it deserves its own keyword!
(Assignee)

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 44626 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.