Middle clicking on a blank section of Firefox opens an alert

RESOLVED DUPLICATE of bug 414345

Status

()

Firefox
Menus
--
trivial
RESOLVED DUPLICATE of bug 414345
9 years ago
9 years ago

People

(Reporter: hy71194@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

If you right click on Firefox in a place where there is no URL, it opens an alert. It never used to do this in the older Firefox versions.

Screenie: http://i32.tinypic.com/307lrhl.png

Reproducible: Always

Steps to Reproduce:
1. Find a blank spot
2. Scroll wheel click
Actual Results:  
Alert pops up.

Expected Results:  
Had the little circle that allows you to scroll up and down by moving your mouse up

OR

nothing.

Default Firefox, happens without any addons installed either.
Where do you click? Inside the location bar or in the content area?
(Reporter)

Comment 2

9 years ago
Inside the content area, ie, anywhere in the highlighted area:
http://img338.imageshack.us/img338/2884/screenshot005.png

[Just playing around a bit with Shutter :D]

Comment 3

9 years ago
I seem to get this, too, on Fedora 11.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
So it depends on your configuration. By default a middle click will use the clipboard content to open it. If you have selected text in the clipboard it will not work and produce this alert. It will only work with supported protocols. You can disable it by open "about:config" in the location bar and search for middlemouse.contentLoadURL. Flag this pref to false.

See bug 282634 which is about setting this pref to false by default and is wontfix. Marking this bug as invalid.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 5

9 years ago
There is bug 414345 about making Firefox look for URIs before pasting.
(In reply to comment #0)
> Steps to Reproduce:
> 1. Find a blank spot
> 2. Scroll wheel click
> Actual Results:  
> Alert pops up.

Updating summary to reflect the initial steps.

Thanks Kevin. Looks like we should dupe this bug against bug 414345.
Resolution: INVALID → DUPLICATE
Summary: Right clicking on a blank section of Firefox opens an alert → Middle clicking on a blank section of Firefox opens an alert
Duplicate of bug: 414345

Comment 7

9 years ago
(In reply to comment #4)
> See bug 282634 which is about setting this pref to false by default and is
> wontfix. Marking this bug as invalid.

There is also bug 415665, which will effectively disable the function of middlemouse.contentLoadURL by default on Linux (since autoscroll takes precedence if both are enabled).
You need to log in before you can comment on or make changes to this bug.