Last Comment Bug 5040 - Turn on support of external entitity replacement
: Turn on support of external entitity replacement
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: XML (show other bugs)
: Trunk
: All All
: P1 major (vote)
: M8
Assigned To: Nisheeth Ranjan
: tao
Mentors:
http://www.mozilla.org/projects/intl/...
Depends on: 8251 8254 8255
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-13 13:29 PDT by tao
Modified: 1999-07-07 12:30 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description tao 1999-04-13 13:29:25 PDT
For localization purpose, we need the parser to support general entities
declared in the external DTD file. (XML spec says an entity is internal if
the entity definition is an EntityValue; otherwise, it is an external one).

Also, the parser needs to provide a callback hook so that the locale
information could be used to locate and fetch the language-specific DTD.
Comment 1 tao 1999-04-13 13:32:59 PDT
Add URL to XUL localizability spec. Also assign QA contact.
Comment 2 Nisheeth Ranjan 1999-04-13 20:51:59 PDT
Accepting bug and changing component to XML.
Comment 3 Nisheeth Ranjan 1999-04-28 17:35:59 PDT
Catalin is working on this and from my talk with him yesterday, I think this
won't make it in time for M5.  So, I'm moving this bug to M6, assigning this to
Catalin and putting myself on the cc list.
Comment 4 tao 1999-06-15 16:21:59 PDT
The status of it:

1. It takes absolute URL as the systemid only.
2. It need doctype declaration in the DTD file. This shouldn't be the case.
3. It does nou support co-existence of internal and external DTD subset yet.

I'll file separate bugs on them.
Comment 5 cata 1999-06-16 10:49:59 PDT
It's in, but the code is #ifdef'ed. Reassigning to Nisheeth so he can final test
& review and turn the flag on.
Comment 6 Nisheeth Ranjan 1999-06-16 14:54:59 PDT
Accepting bug...

I tried testing the following XML and, with EXTERNAL_ENTITY_SUPPORT enabled,
nothing displays in viewer:

<?xml version="1.0">
<test>
this text should display.
</test>
---

Ccing cata so that he can also take a look at this.
Comment 7 Nisheeth Ranjan 1999-06-16 14:56:59 PDT
Updating summary.
Comment 8 cata 1999-06-16 15:02:59 PDT
I thought the correct syntax was:
<?xml version="1.0"?>
(please note the final "?")

Maybe that's the problem?
Comment 9 Nisheeth Ranjan 1999-06-16 15:54:59 PDT
You are right about the syntax.  But, an error message should show up in the
viewer.  Currently, nothing shows up.
Comment 10 Nisheeth Ranjan 1999-06-16 16:29:59 PDT
Oops, my bad.  It seems that this behavior was occurring earlier also...

I'm in there testing more as I type...
Comment 11 Nisheeth Ranjan 1999-06-17 16:31:59 PDT
My testing did not uncover new issues: everything I found already has bugs open
or was reported by James Clark.

Clearing status because basic XML does display fine with these changes enabled.
Changing summary to reflect that only enablement remains.

I'm setting the target milestone for the resolution of this bug to M8.  We need
to address James Clarks' concerns as well as resolve bugs 8251, 8254, and 8255
before we turn this on for everybody.  Adding those bugs to the bug dependency
list.
Comment 12 Nisheeth Ranjan 1999-07-02 14:59:59 PDT
I just turned this on in the builds of all platforms.  Thanks a lot to James for
providing a patch to expat that adds this new feature.  Many thanks to Tao for
integrating James' changes into the mozilla codebase.
Comment 13 tao 1999-07-07 12:30:59 PDT
Verified with jul-07-99 build.

Note You need to log in before you can comment on or make changes to this bug.