Closed Bug 504002 Opened 11 years ago Closed 11 years ago

Bookmark toolbar condensed to chevron ">>" button on initial browser load/new window

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 447571

People

(Reporter: cc, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Note: I have searched thoroughly and noted many bugs that were closed for being "duplicates" of a bug regarding bookmark toolbar condensing when resizing or minimizing/restoring browser windows, but this does not to be the same behavior I am experiencing.

When the bookmark toolbar is on the same line as the URL bar (bookmarks on the left, URL on the right), the bookmark buttons are all condensed into a single ">>" button and the URL bar is stretched to fill the rest of the available space.  If the toolbar area is right-clicked, and "Bookmarks Toolbar" is disabled and then reenabled, the bookmark buttons will properly display side-by-side.  If a new window is opened, however, the problem repeats.

A previous bug report indicated that this happened when the Bookmarks toolbar was on its own line by itself.  In my testing, this seems to be fixed; Having the Bookmarks toolbar be on a line by itself works "as expected".  However, if the Bookmarks toolbar and URL bar share the same line, the URL bar seems to be greedily hogging all available space whenever a new window is opened.

Affects Firefox 3.5 release and prior betas.

Reproducible: Always

Steps to Reproduce:
1. Customize toolbars and drag Bookmarks toolbar and URL/address bar onto the same line.
2. Open a new window, or load Firefox 3.5 if it is not running.
3. Bookmark buttons on toolbar are hidden and only the expandable ">>" chevron button is displayed.
Actual Results:  
Bookmark buttons are condensed.
Example screenshot: http://www.terminaldogma.net/ff35_example1.png



Expected Results:  
Bookmark buttons should display side-by-side with URL bar.
Example screenshot: http://www.terminaldogma.net/ff35_example2.png

Note: although I am using a custom theme in these screenshots, I have tested with the default Firefox theme and the behavior is identical.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is still a dupe.  Please try the extension linked in bug 447571 comment 66
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
You need to log in before you can comment on or make changes to this bug.