can't paste with middle button in composers

VERIFIED DUPLICATE of bug 50606

Status

()

Core
Editor
P3
major
VERIFIED DUPLICATE of bug 50606
18 years ago
17 years ago

People

(Reporter: R.K.Aa., Assigned: rubydoo123)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
noticed yesterday and it's still present in linux 2000082513:

Selecting text in third party app and then trying to paste into mail-compose or
composer with middle mouse-button: nothing is pasted.

Perhaps related:
When these editors get started, a couple of "new" messages appear in console:
failed to get command manager number 3
failed to get command manager number 2
(Reporter)

Comment 1

18 years ago
regression keyword.
(additional info: can paste OK in url-bar, forms etc.)
Keywords: regression
(Reporter)

Comment 2

18 years ago
This one is still alive in build 2000-082908.

Comment 3

18 years ago
Is it possible you're seeing the other bug (probably assigned to saari, I don't
have the number), that you have to click in the content area to set focus before
you can do much of anything in composer?

I saw this happen the first time I tried, but then when I clicked in the content
area, after that I've been able to paste from rxvt, emacs, and NS 4.7.  So I'm
guessing the problem is the lack of focus, not a problem with
middle-mouse-paste.
(Reporter)

Comment 4

18 years ago
i have clicked once, twice and thrice.
(Reporter)

Comment 5

18 years ago
Seems I can paste from third party applications that have a specific "copy"
feature. Not with middle button (still) but with "Edit/paste".

Comment 6

18 years ago
Pav, who owns linux clipboard, should in on this.  Pav, do you see this?  I
don't (at least, not after first clicking in the editor content area).

Comment 7

18 years ago
this works here too.  just a guess, try applying the latest patch on bug 50606
and see if this fixes your problem.
(Reporter)

Comment 8

18 years ago
Didn't apply patch - saw it was checked in and pasting now works again.
Build 2000-083008.
Resolving this as dup of 50606 just for the record.

*** This bug has been marked as a duplicate of 50606 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
verified in 8/31 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.