[IE7, JavaScript-disabled] "Go" button in language/locale picker doesn't work

VERIFIED FIXED in 5.0.9

Status

--
minor
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: stephend, Assigned: jbalogh)

Tracking

unspecified
5.0.9
x86
Windows Vista

Details

(Whiteboard: [dammitie], URL)

Definitely an edge case, but if you disable Active Scripting in IE 8 and visit http://preview.addons.mozilla.org, the language/locale picker's "Go" button won't submit.

Thanks to Raymond for the find :-)
(Assignee)

Updated

9 years ago
Assignee: nobody → jbalogh
(Assignee)

Comment 1

9 years ago
I can't reproduce this, and the language picker form looks good (just eyeballing it).

BTW, "active scripting" appears to be an alias for "javascript".  I'm able to toggle the "active scripting" selector by disabling script in the dev tools.
This is a trivial fix:

http://www.thefutureoftheweb.com/blog/button-wont-submit-in-ie

If you have time to do it, Jeff, go ahead, otherwise I can.
Target Milestone: --- → 5.0.9
(Assignee)

Comment 3

9 years ago
Ah, thanks Fred.  I'm pretty sure you guys are testing this in IE7, since msdn says "In IE8 mode, the default value is submit. In other compatibility modes and earlier versions of Internet Explorer, the default value is button.".
Summary: [IE 8, JavaScript-disabled] "Go" button in language/locale picker doesn't work if JavaScript is disabled in Internet Explorer 8 → [IE7, JavaScript-disabled] "Go" button in language/locale picker doesn't work if JavaScript is disabled in Internet Explorer 8
Whiteboard: [dammitie]
(Assignee)

Comment 4

9 years ago
r49172
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
Summary: [IE7, JavaScript-disabled] "Go" button in language/locale picker doesn't work if JavaScript is disabled in Internet Explorer 8 → [IE7, JavaScript-disabled] "Go" button in language/locale picker doesn't work
This was indeed broken only in IE 7 with JS disabled (I tested on prod); verified on staging using IE 7 (tested to ensure it works in Firefox/IE 8, too).
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.