Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 504184 - shift reload pulls files with the same name multiple times
: shift reload pulls files with the same name multiple times
Status: RESOLVED DUPLICATE of bug 497665
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2009-07-14 14:43 PDT by jfftck
Modified: 2010-05-08 10:04 PDT (History)
7 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description jfftck 2009-07-14 14:43:02 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

I noticed that if I do a shift reload the an image file is being downloaded as many times as it appears on the page. I have a google map that has 100+ markers that can take over 2 mins when I normally have the same page render in 10-30 seconds. I did not have this problem with any build of Firefox 3.0, and I am doing test on a local machine, so I do not have a test case at this moment.

Reproducible: Always

Steps to Reproduce:
1.Load a page with many images with the same name, like google maps with many markers.
2.Do a shift reload to force files to be pulled from the server.
Actual Results:  
The image is downloaded even after the first image completes downloading.

Expected Results:  
The image file should only be downloaded once and then use the cache to render the rest.
Comment 1 jfftck 2009-07-15 06:28:57 PDT
Also, it looks to not use the cache until I do a refresh without holding shift.
Comment 2 Matt Jamison 2009-08-19 09:58:11 PDT
Same issue here, the cache is not used after shift reload until after another reload without holding shift.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2
Comment 3 Jon Crump 2009-10-17 12:31:19 PDT
My configuration:
(Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv: Gecko/20090824 Firefox/3.5.3)

I can confirm that the google-maps test-case offered by fails on my configuration in the manner described.

Reproducible: every time. 

Here is a test case that is a stripped down version of my particular use-case:

Multiple images are preloaded via javascript.

On initial load, or a load into new window or tab, a simple animation based on img.src replace pulls the pre-loaded images from cache and proceeds as expected.

On a simple reload (click on toolbar reload button), the animation still proceeds as expected, drawing images from cache.

On shift-reload, however, preloaded images are ignored. Each image is loaded from the server with each iteration until there's a normal reload.

In my particular use case (temporarily visible at  the problem is aggravated by something else I can't identify. In this case, further reloads don't help. The only way to get the page to use cached images for the animation is to load it again into a new window or tab.
Comment 4 Héctor Paz 2010-01-12 07:34:49 PST
I can confirm the bug for firefox 3.5 and firefox 3.6 (Windows and Linux). If the same element is called two or more times in the html, with Ctrl+F5 the element will be downloaded as many times as it appears.

Firebug reports all the calls: . Also the behavior is confirmed on the web server side with the same element being called many times.

Changing the element from being called from the html to the css solves the issue.
Comment 5 j.j. 2010-03-15 19:34:53 PDT
Isn't this a dup of Bug 497665, which is fixed?
Comment 6 j.j. 2010-05-08 10:04:13 PDT

*** This bug has been marked as a duplicate of bug 497665 ***

Note You need to log in before you can comment on or make changes to this bug.