Copy text + left-right click opens web page www."copied text".com

RESOLVED DUPLICATE of bug 306857

Status

()

RESOLVED DUPLICATE of bug 306857
10 years ago
10 years ago

People

(Reporter: alexandros.java, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090701 Ubuntu/9.04 (jaunty) Shiretoko/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090701 Ubuntu/9.04 (jaunty) Shiretoko/3.5

When I copy text and left-right click, I get sent to www."copied text".com

Reproducible: Always

Steps to Reproduce:
1.Type on the search bar "bugzilla" and copy it
2.On a random web page do a left+right click (or even on a new tab)
Actual Results:  
I'm directed to www.bugzilla.com or to make it more general I'm directed to www."copied text".com (replace "copied text" with whatever text you copied)

Expected Results:  
This behaviour should not exist

* Using Shiretoko binary found in the Ubuntu Jaunty repository
* Possible keywords: papercut
Please read: http://kb.mozillazine.org/Middlemouse.contentLoadURL
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Please read: http://kb.mozillazine.org/Middlemouse.contentLoadURL

I set middlemouse.contentLoadURL in about:config to false and the bug went away.
However, I don't think that this should be set by default to true. It's very annoying if you use a touchpad instead of a mouse and you mistakenly trigger left+right click by touching the top-right corner ;-)

Comment 3

10 years ago
Left and right click emulates a middle click in most Xwindows setups.
You can set this preference so that this does not happen.

See (not ubuntu specific) https://wiki.ubuntu.com/X/Config/Input#Example:%20Disabling%20L+R%20mouse%20button%20paste%20on%20a%20two-button%20mouse

I personally like the middle click.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 306857
You need to log in before you can comment on or make changes to this bug.