Reverse order of newly installed addons, pending restart

RESOLVED INVALID

Status

()

enhancement
RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: stream, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: 

When installing more than 4 addons at once without restart, the 5th addon is hidden and all after the 5th.

Its about the Installation tab in Addons Manager.

If the order is reversed, e.g. the last installed addon is on top of previous, this problem will gone.

Reproducible: Always

Steps to Reproduce:
1. Install 4 addons
2. Install some more
Actual Results:  
You cant see the installation progress of 5th, 6th addons etc.

Expected Results:  
Latest installed addon on top of all others.
Valid enhancement, but probably not going to spend time to fix this before the UI is reworked
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Updated

9 years ago
Blocks: 550048
Intended behavior is for list to default to "Last Updated" order after a restart, so the most recently updated add-on would be at the top in List View.
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk

Comment 3

2 years ago
With WebExtensions being restartless I dont think this is sill valid. UI problems remain in bug 1329884.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.