PAC: js uncaught exception when personal toolbar used & bad proxy settings

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
minor
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
i set the proxy dialog to 'use automated proxy config script:' and left the
field blank.

typing in a url to location bar did nothing, which is fine. clicking the links
in the personal toolbar (tinderbox, etc) gave:

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIBrowserInstance.loadUrl]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: OpenBookmarkURL :: line 691"  data:
no]
QA Contact: sairuh → claudius
pardon the spam: personal toolbar bugs should go into the Bookmarks component.
so, i'm moving the existing ones from xp apps/xp apps: gui to there...
Component: XP Apps: GUI Features → Bookmarks

Comment 2

17 years ago
WFm on 2001071004 on Win2K.  No JS errors.

Jeremy, can you reproduce this on a recent build?  If not, we can close this 
bug as WORKSFORME.

Comment 3

17 years ago
Resolving as WORKSFORME

If you see this behaviour on a recent build, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
I need to check this out, so I'm moving it to networking and making a testcase...
Component: Bookmarks → Networking
Keywords: testcase
QA Contact: claudius → benc
Summary: js uncaught exception when personal toolbar used & bad proxy settings → PAC: js uncaught exception when personal toolbar used & bad proxy settings
You need to log in before you can comment on or make changes to this bug.