Closed Bug 504495 Opened 11 years ago Closed 11 years ago

Windows CE has no context menu for bookmarks toolbar, sometimes crashes trying

Categories

(Firefox :: Menus, defect)

ARM
Windows CE
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: Dolske, Assigned: Dolske)

References

Details

(Keywords: verified1.9.2, Whiteboard: [nv])

Attachments

(1 file)

The bookmarks toolbar is off by default. But if you show it and then try to right click on it or any items in it (to bring up the context menu), nothing happens. In trying this a few times in a row, I usually crash shortly after trying to do this.
Whiteboard: [nv]
Hrm, can you do a debug build and grab a stack for this crash?
I can repro this on  Mozilla/5.0 (Windows; U; WindowsCE 6.0;
en-US; rv:1.9.2a1pre) Gecko/20090727 Firefox/3.6a1pre.  No debug build here though.
Blocks: 506810
So, first time playing with the kernel debugger, and it seems to indicate we're crashing in nsClipboard::GetNativeClipboardData() at:

  mTransferable->FlavorsTransferableCanImport(getter_AddRefs(flavorList));
Setting a breakpoint (in the normal VS2008 debugger) before, after, and in this call confirms that's where we're croaking. I'm not sure why, though. I hit the breakpoint before the call, but not the one after or in FlavorsTransferableCanImport(). mTransferable isn't null here, so I'm not sure why it's dying.

The call stack shows this being called from nsBaseClipboard::GetData(). There's only one frame above that, something about native code, so I assume we're being called from JIT code?
Attached patch Patch v.1Splinter Review
Durrrr... s/mTransferable/aTransferable/.

This fixes the crash, but the context menu still sometimes doesn't show up. I think this may be bug in the OS, we seem to rely on getting WM_CONTEXTMENU to dispatch the context menu event, but sometimes we just never get it.
Assignee: nobody → dolske
Attachment #392402 - Flags: review?(vladimir)
I can reproduce the content menu sometimes-not-showing problem in an explorer window too, although it seems a little harder to make happen.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attachment #392402 - Flags: approval1.9.2?
Attachment #392402 - Flags: approval1.9.2?
Pushed to 192: http://hg.mozilla.org/releases/mozilla-1.9.2/rev/1bf16951d1be

Sure would be nice if bugzilla had a status192 flag, now that we've branched!
Keywords: fixed1.9.2
Duplicate of this bug: 510834
no more crash.  Verified fix on Mozilla/5.0 (Windows; U; WindowsCE 6.0; en-US; rv:1.9.2a2pre) Gecko/20090901 Namoroka/3.6a2pre
Status: RESOLVED → VERIFIED
Adding verified keyword based on Comment 10.
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.