FF crashes on start with segmentation fault libimgicon.so [@ 0xb4f47a19 | imgRequest::OnStopRequest]

RESOLVED INVALID

Status

()

Core
ImageLib
--
critical
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Leo Plaw, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.0) Gecko/20090623 SUSE/3.5.0-7.1 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.0) Gecko/20090623 SUSE/3.5.0-7.1 Firefox/3.5

FF crashes on start with segmentation fault /usr/lib/firefox/components/libimgicon.so



Reproducible: Always

Steps to Reproduce:
1. Start FireFox
2.
3.
Actual Results:  
FF crashes on start with segmentation fault libimgicon.so

However, starting in safe-mode works. Then exit and then start again in normal mode FF runs.

Disabling all plugins makes no differnce.

Deleting the profile directory makes no difference.

Uninstalling and reinstalling FF makes no difference.

Uninstalling and reinstalling the XULrunner makes no difference.

Expected Results:  
Firefox runs.

OS:  Linux 2.6.27.23-0.1-default i686
  Current user:  neoarttec@linux-hfg8
  System:  openSUSE 11.1 (i586)
  KDE:  4.2.96 (KDE 4.2.96 (KDE 4.3 RC2)) "release 142"


rpm -qa --qf='%{name}-%{version}-%{release}-%{arch}\t%{distribution}\n' | grep -i mozilla

mozilla-nspr-4.8-1.1-i586       mozilla / openSUSE_11.1
libnsssharedhelper0-1.0.6-1.8-i586      mozilla / openSUSE_11.1
MozillaThunderbird-2.0.0.22-4.1-i586    mozilla / openSUSE_11.1
MozillaThunderbird-translations-2.0.0.22-4.1-i586       mozilla / openSUSE_11.1
mozilla-xulrunner191-debuginfo-1.9.1.0-9.1-i586 mozilla / openSUSE_11.1
kaffeine-mozilla-0.2-0.pm.1-i686        openSUSE 11.1 (i686)
mozilla-xulrunner191-gnomevfs-1.9.1.0-9.1-i586  mozilla / openSUSE_11.1
libfreebl3-3.12.3-6.1-i586      mozilla / openSUSE_11.1
MozillaFirefox-translations-3.5.0-7.1-i586      mozilla / openSUSE_11.1
mozilla-xulrunner191-translations-1.9.1.0-9.1-i586      mozilla / openSUSE_11.1
MozillaFirefox-debuginfo-3.5.0-7.1-i586 mozilla / openSUSE_11.1
mozilla-nss-3.12.3-6.1-i586     mozilla / openSUSE_11.1
MozillaFirefox-3.5.0-7.1-i586   mozilla / openSUSE_11.1
MozillaFirefox-branding-openSUSE-3.5-12.1-i586  mozilla / openSUSE_11.1
mozilla-xulrunner191-1.9.1.0-9.1-i586   mozilla / openSUSE_11.1


Program received signal SIGSEGV, Segmentation fault.
0xb4f47a19 in ?? () from /usr/lib/firefox/components/libimgicon.so

(gdb) bt
#0  0xb4f47a19 in ?? () from /usr/lib/firefox/components/libimgicon.so
#1  0xb685e323 in imgRequest::OnStopRequest (this=0xb107e3a0, aRequest=0xb1066fdc, ctxt=0x0,
    status=2152988677) at imgRequest.cpp:856
#2  0xb6859656 in ProxyListener::OnStopRequest (this=0xb0e55240, aRequest=0xb1066fdc, ctxt=0x0,
    status=2152988677) at imgLoader.cpp:1595
#3  0xb676b283 in nsBaseChannel::OnStopRequest (this=0xb1066fb0, request=0xb0e41060, ctxt=0x0,
    status=2152988677) at nsBaseChannel.cpp:680
#4  0xb6771cfd in nsInputStreamPump::OnStateStop (this=0xb0e41060) at nsInputStreamPump.cpp:576
#5  0xb6772021 in nsInputStreamPump::OnInputStreamReady (this=0xb0e41060, stream=0xb107aec8)
    at nsInputStreamPump.cpp:401
#6  0xb6f1aacf in nsInputStreamReadyEvent::Run (this=0xb0e44dc0) at nsStreamUtils.cpp:111
#7  0xb6f2e620 in nsThread::ProcessNextEvent (this=0xb79a63d0, mayWait=1, result=0xbfffa854)
    at nsThread.cpp:510
#8  0xb6eff1a0 in NS_ProcessNextEvent_P (thread=0x8, mayWait=1) at nsThreadUtils.cpp:227
#9  0xb6e7fc94 in nsBaseAppShell::Run (this=0xb4e5fb00) at nsBaseAppShell.cpp:170
#10 0xb6d4bae4 in nsAppStartup::Run (this=0xb4eea310) at nsAppStartup.cpp:193
#11 0xb6702d88 in XRE_main (argc=2, argv=0xbfffefa4, aAppData=0xb7921980) at nsAppRunner.cpp:3298
#12 0x08049f1f in ?? ()
#13 0xb7c5b705 in __libc_start_main () from /lib/libc.so.6
#14 0x080498e1 in ?? ()

Updated

9 years ago
Component: General → ImageLib
Keywords: crash
Product: Firefox → Core
QA Contact: general → imagelib
Summary: FF crashes on start with segmentation fault libimgicon.so → FF crashes on start with segmentation fault libimgicon.so [@ 0xb4f47a19 | imgRequest::OnStopRequest]
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 1

9 years ago
Created attachment 396059 [details]
Firefox bactrace - Segmentation fault - /lib/libc.so.6

Problem still exists after upgrading several times to the latest Firefox and XULrunner.
(Reporter)

Comment 2

9 years ago
Original crash on start up problem was solved by installing a different FF theme.

Problem now occurs with dialog boxes upon option selection.

File requesters, alert boxes

Comment 3

8 years ago
caused by theme per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Assignee)

Updated

7 years ago
Crash Signature: [@ 0xb4f47a19 | imgRequest::OnStopRequest]
You need to log in before you can comment on or make changes to this bug.