Can't add SMTP server

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Account Configuration
P1
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Richard Zach, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When I add a second SMTP server, it does not show up in the SMTP server list in
the account manager.

To reproduce:
1. Open account manager
2. Select SMTP servers
3. Click "Advanced"
4. Click "Add"
5. Enter SMTP server address, click OK

Expected result: new server shows up in list
Actual result: no new server entry

Linux build 2000.08.26.08
(Assignee)

Comment 1

18 years ago
argh. this dialog hasn't changed in weeks. what happens if you try to 
resize the window? or maybe close the dialog and reopen it? is the server there? 
I'm wondering if it's just a tree refresh problem..
(Reporter)

Comment 2

18 years ago
Nope, neither worked.  First time I tried this, so I can't tell if it's
regressed or just never worked.
(Assignee)

Comment 3

18 years ago
it definately used to work :)
thanks for the info, I'll poke into it
Status: NEW → ASSIGNED

Comment 4

18 years ago
If this is a problem, we'll want this for the release.   nominate nsbeta3
esther - do you have the same problem?

(hi, Richard - good to see you in bug reports again)
Keywords: nsbeta3
QA Contact: lchiang → esther

Comment 5

18 years ago
+, P1 per mail triage
Keywords: mail4
Priority: P3 → P1
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Comment 6

18 years ago
to pdt: this is a P1 due to loss of functionality. One of the new features we 
advertise for Seamonkey is multiple SMTP support.

Comment 7

18 years ago
Yes, the problem exists on all platforms.  I tested 08-28 builds on win98, linux 
and mac.

Comment 8

18 years ago
PDT agrees P1

Comment 9

18 years ago
I think a js exception is getting thrown here:

function updateControls() {

    dump("Update controls..\n");

    var isSecure = false;
        document.getElementById("smtp.isSecure").checked;


isSecure doesn't seem to be a method on the smtp server.
(Assignee)

Comment 10

18 years ago
that's commented out in the current tip..
Sorry, I haven't had a chance to look at this yet

Comment 11

18 years ago
Ok, I have a fix for this.
Assignee: alecf → bienvenu
Status: ASSIGNED → NEW

Comment 12

18 years ago
Created attachment 13967 [details] [diff] [review]
proposed fix

Comment 13

18 years ago
if I take out all the stuff in updateControls, this works again. Can I get an r=?
Status: NEW → ASSIGNED
(Assignee)

Comment 14

18 years ago
oh how frustrating - I thought this was commented out in the tip, turns out it's 
commented out in my tree - I must have forgotten to check this in long ago.. go 
ahead and check yours in
r=alecf

Comment 15

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: esther → nbaca

Comment 16

18 years ago
Build 2000-09-15-06M18: NT4, Linux 6.0, Mac 9.04

After step #5 the new SMTP server appears in the list and remains there for the 
current session. 

After exiting and restarting then it disappears. Should I log a new bug? The 
default smtp server is nsmail-2, then I added nsmail-1. After exiting and 
restarting, nsmail-1 is not displaying. I searched for all SMTP entries in the 
prefs file and they are:

user_pref("mail.smtp.defaultserver", "smtp1");
user_pref("mail.smtpserver.smtp1.hostname", "nsmail-2");
user_pref("mail.smtpserver.smtp1.username", "");
user_pref("mail.smtpserver.smtp2.auth_method", 0);
user_pref("mail.smtpserver.smtp2.hostname", "nsmail-1");
user_pref("mail.smtpserver.smtp2.username", "");
user_pref("mail.smtpservers", "smtp1,smtp1,smtp2");

(Assignee)

Comment 17

18 years ago
nooo.. not again!! how does this bug keep coming back?!
I dunno. Can you experiement s'more? like adding a few more smtp servers, 
resizing the window, etc? I'll try on this end too.
(Assignee)

Comment 18

18 years ago
ugh, I think I figured out part of what's going on - the server is getting
added, but the first time you open the dialog, you only see one server, the
default one. I don't know why.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 19

18 years ago
back to alec.
Assignee: bienvenu → alecf
Status: REOPENED → NEW
(Assignee)

Comment 20

18 years ago
ok,  this is now fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 21

18 years ago
Build 2000-09-19-05M18: NT4
Build 2000-09-19-08M18: Linux 6.0
Build 2000-09-18-08M18: Mac 9.04
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.