default tab show only a message and no other panes [dead end UI]

RESOLVED FIXED in Thunderbird 3.0b4

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: ovidiu.grigorescu, Assigned: standard8)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b4
x86
Windows Vista
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact][workaround comment 34])

Attachments

(5 attachments)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

str:
-select a folder (inbox) and see some msg in the tree
-middle click to open 3 msg in other tabs, one by one, without view the tab
-go to msg 3, 2 ,1 tabs to see, ok
-after have been to each msg tabs, note the last viewed, observe all tabs and default one

result: all tabs including the default tab show the respective msg (1) instead of panes or other msg. 

!!!
If the order of viewing tabs is 3,1,2, then the msg2 will be the sticky one, the last viewed after viewing all tabs. The momment it goes crazy is after seen each msg tab.

Also while see msg 3, 2, again 3 already 3 is showing 2 content. Basically you are not stucked untill all tabs are viewed, though the default tab is already messy after first msg tab seen and you don't get folders or tree no more.

+no way to escape this dead end tabs UI but restart
+in such a msg tab the header buttons not showing except for others
(see attachment pic)

expected: to end up with the normal panes in the default tab, each other tab to contain respective msg.

repro: always


regression:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1pre) Gecko/20090709 Shredder/3.0b3pre
works like a charm, though I remember that kind of bug was here before 3pre ..
maybe bug481855
(Reporter)

Comment 1

10 years ago
Also:
-The same happens to search tabs (gloda) ending with a default tab that shows the content of the search tab I just closed. (Instead of the steps above with msg tab)
-Opening folders in another tab does not update the folderpane and does not show selected msg body in the msg pane (bug 392330 ?)
(Reporter)

Updated

10 years ago
Blocks: 489128
I am not able to reproduce this using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090716 Lightning/1.0pre Shredder/3.0b4pre ID:20090716172119

Couple diffs here
I'm using winxp
I don't have a 3 button mouse, so opened with right context click
I'm using pop3

Even opening multiple tabs on collapsed newsgroup threads, seems to work OK
The most likely explanation is that something is throwing an exception and breaking the tab switch.  ovidiu, does this happen if you run in safe mode?  Does anything show up in the Thunderbird "error console" window?  Does anything show up on the command line (assuming you run from the command line or pass "-console" (I think that's the arg?)?
(Reporter)

Comment 4

10 years ago
not in safe mode, not in another profile, not on another xp machine

So generally I find it WFM, only on this profile always repro. Although there is no extension and it's supposed to be a clear profile. The only thing I can think of is that is installed on top of a rc1-2 (thus the paths and profile folder names in the console below ..) ?


error console shows this on startup:

Error: selectedMenuItem is undefined
Source File: chrome://messenger/content/search.xml
Line: 255

!!!on the first "wrong" tab switch (display wrong content) and on every wrong tab switch from that point :

Error: menuItems[0] is undefined
Source File: chrome://messenger/content/search.xml
Line: 301


console got this when selecting a folder, subfolder of an inbox on a pop:
(nothing else on the specific bug str or other moves)

``` EXCEPTION DURING NOTIFY: chrome://messenger/content/search.xml:301: TypeErro
r: menuItems[0] is undefined
STACK: setSearchCriteriaText()@chrome://messenger/content/search.xml:301
ClearQSIfNecessary()@chrome://messenger/content/searchBar.js:198
FolderDisplayWidget_onDisplayingFolder()@chrome://messenger/content/folderDispla
y.js:884
DBViewWrapper__enterFolder()@file:///C:/lucru/tbtest/tb3.0b1rc1en/thunderbird/mo
dules/dbViewWrapper.js:1152
DBViewWrapper__folderLoaded([object XPCWrappedNative_NoHelper])@file:///C:/lucru
/tbtest/tb3.0b1rc1en/thunderbird/modules/dbViewWrapper.js:1129
FolderNotificationHelper_OnItemEvent([object XPCWrappedNative_NoHelper],[object
XPCWrappedNative_NoHelper])@file:///C:/lucru/tbtest/tb3.0b1rc1en/thunderbird/mod
ules/dbViewWrapper.js:248
updateFolder([object XPCWrappedNative_NoHelper])@:0
FolderNotificationHelper_notifyOnLoad([object XPCWrappedNative_NoHelper],[object
 Object],[object XPCWrappedNative_NoHelper])@file:///C:/lucru/tbtest/tb3.0b1rc1e
n/thunderbird/modules/dbViewWrapper.js:129
DBViewWrapper_open([object XPCWrappedNative_NoHelper])@file:///C:/lucru/tbtest/t
b3.0b1rc1en/thunderbird/modules/dbViewWrapper.js:821
FolderDisplayWidget_show([object XPCWrappedNative_NoHelper])@chrome://messenger/
content/folderDisplay.js:657
FolderPaneSelectionChange()@chrome://messenger/content/commandglue.js:350
onselect([object Event])@chrome://messenger/content/messenger.xul:1
select(2)@:0
onxblmousedown([object MouseEvent])@chrome://global/content/bindings/tree.xml:97
5
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 5

10 years ago
(In reply to comment #4)
> !!!on the first "wrong" tab switch (display wrong content) and on every wrong
> tab switch from that point :
> 
> Error: menuItems[0] is undefined
> Source File: chrome://messenger/content/search.xml
> Line: 301

I know this error message from Bug 455248.
Hi ovidiu.

I have this same issue on past days.

First I have disinstalled all of my extension, but I'm not sure that this has any effects. I have try also with new profile, but I dont think this has effect on the resolved workaround

I have resolved simple closing TB and deleting (in my profile folder) the file localstore.rdf... I  suspect of this because in safe-mode I dont have problem: but in safe-mode TB use localstore-safe.rdf.

For me this bug now can close as WFM if you dont have other opinion.
(Reporter)

Comment 7

10 years ago
yep. deleting (rename) localstore.rdf solved it
I'll WFM then, but is this still not a possible issue for certain upgrades? Or install over certain profiles? 

[Basically this was a profile used only for Beta or RC's..]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 505928

Comment 9

10 years ago
Not sure that RESOLVED WORKSFORME is a correct resolution. This requires a manual file find and delete after upgrade.

At the very least, this means that there is a path that leads to corruption of localstore.rdf. Should we create a bug for the upgrade folks to handle this case? I was not using an RC before, but TB 2.

Please let me know of the proper protocol
(Reporter)

Comment 10

10 years ago
That's exactly why I worry. Upgrading from tb2 to lead to this.
Maybe I'll try to upgrade a tb2 to see.

FWIW, I installed it in the directory of the respective rc2 installation from the exe installer, no zip or other way. Normal case for the usual user.
Duplicate of this bug: 506846
(Assignee)

Comment 12

10 years ago
Reopening, I think this is worthy of some more investigation as to the cause of the error and what is happening.

As a first step I think it would be good to see if there's a localstore.rdf that will reliably produce this issue in different profiles - hence let developers reproduce.
Status: RESOLVED → UNCONFIRMED
Flags: blocking-thunderbird3?
Keywords: qawanted
Resolution: WORKSFORME → ---
Attached my localstore.rdf that raise the issue for investigation
Keywords: testcase
(Reporter)

Comment 14

10 years ago
I tried my problematic rdf on various profiles that were working. If placing this rdf in the profile it leads to the exact issue. 

I'll also try the other one attached before.
(Reporter)

Comment 15

10 years ago
tried the other (first) attached localstore.rdf and reproduced exactly
(In reply to comment #15)
> tried the other (first) attached localstore.rdf and reproduced exactly

	
I remember the first time that I have this issue, I just installed Enigmail (trunk). But then even after I uninstall Enigmail had the same problem.
For you is the same, ovidiu?
(Reporter)

Comment 17

10 years ago
Don't think I used it on tb3 and the profile was never under tb2 (nor updated tb2). The profile was a fresh one made for tb3 rc's, b1 b2 ... and used with respective rc's and betas, not even nightlies.
I am unable to duplicate the problem on linux or WinXP using the provided localstore.rdf files using beta 3 builds.

I have been able to cause a "``` EXCEPTION DURING NOTIFY: chrome://messenger/content/search.xml:301:" message to be produced, but it doesn't actually break anything.

To those able to reproduce, does anything else show up in the Thunderbird error console window?

Aureliano, are you using Windows Vista too?
(In reply to comment #18)

> To those able to reproduce, does anything else show up in the Thunderbird error
> console window?
Nothing

> Aureliano, are you using Windows Vista too?
No Windows Xp service pack 3

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2pre) Gecko/20090727 Lightning/1.0pre Shredder/3.0b4pre ID:20090727034746

and set on true options-->advanced-->reading and display 

open messages in--> new tab.
Please attach a copy of the "session.json" file from your profile directory that you are able to use to successfully reproduce this problem.  (So, basically, copy the session.json to another file, then run Thunderbird, and assuming the problem reproduces, post the session.json here.)

You may want to scrub any "folderURI"/"messageURI" values in session.json, but please only change the value strings there and don't excise everything.
Posted file session.json
attached session.json requested.

I doubt that is related to session.json, because I can reproduce this issue also in a profile foder with missing session.json.

If attached file not is right, I can send a private email with all strings.
Attachment #391052 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 22

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3 ID:20090715140311

*copied a faulty rdf in xp and got the same. 

*I wached session.json before and after operation (working and not working) and there is no difference in it.

*there was nothing new to error console
The problem has repeated today: I double-click on a message during received a new mail (or when the new mail had just been received).


ps: using know workaround (deleting localstore) I resolved the issue.
Aureliano, did you check if there was any output in the Thunderbird error console window or in the (Windows) console window (assuming you ran Thunderbird in that fashion) when the problem happened?  It's okay if you didn't, but it'd be good to know if the root cause involves an error...
At the momento not, but now, if I repeat the test with "corrupt" localstore created today, I see:

Error: menuItems[0] is undefined
Source File: chrome://messenger/content/search.xml
Line: 301
Duplicate of this bug: 507704
(Assignee)

Comment 27

10 years ago
Andrew, I've just had this happen on the nightly build that I use. No idea what caused it, I haven't had any crashes or anything, afaik I haven't done anything strange and I couldn't reproduce on a different profile. 
Lightning may or may not be an issue - I have it installed and use it at various times.

The symptoms are pretty much as others have mentioned - the errors in comment 4 are what I see.

What I have noticed in the broken profile are:

- in localstore.rdf the RDF description "chrome://messenger/content/messenger.xul#quick-search-menupopup" has value "undefined"
- the searchMode value in the js object for the search text box has value "undefined" (*with* the quotes).
- When selecting the quick search drop-down menu nothing is ticked.
- Selecting something on the quick search drop-down menu "fixes" the searchMode value and TB works as normal again.

So I've got no idea what causes this, but maybe the constructor check should be checking for the string "undefined" to use the default value - at least as a stop-gap solution.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Thanks for the detailed analysis Mark.

I agree on making the search bar more accepting of gibberish input values.

We also should probably take this opportunity to exception-proof (with error reporting) all calls outside the core of FolderDisplayWidget/DBViewWrapper, which mainly means the quick-search code.

Updated

10 years ago
Duplicate of this bug: 509704

Updated

10 years ago
Duplicate of this bug: 509644
Duplicate of this bug: 511286
Whiteboard: [no l10n impact]
(Assignee)

Updated

10 years ago
Target Milestone: --- → Thunderbird 3.0b4

Updated

10 years ago
Duplicate of this bug: 510870

Comment 33

10 years ago
I'm using (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3) and this is a really annoying problem. I don't have Lightning installed. Whenever I open a message (and subsequently open a new tab) then try to switch or close the tab the folders tab doesn't work. When I close (but don't quit-Mac users understand what I mean) Thunderbird, then open it, the folders tab is working but there is a blank tab to the right.
(Assignee)

Comment 34

10 years ago
Taking as I am actually working on a patch for this.

I believe the workaround is to just alter the quick search menu (in the search box on the toolbar) so that there is a tick against one of the items.

How it gets to the undefined state I haven't worked out yet, but that should fix it for a while at least.
Assignee: nobody → bugzilla
Whiteboard: [no l10n impact] → [no l10n impact][workaround comment 34]

Comment 35

10 years ago
I not only get:

Error: menuItems[0] is undefined
Source File: chrome://messenger/content/search.xml
Line: 301

but I also get:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml :: removeProgressListener :: line 390"  data: no]
(Assignee)

Comment 36

10 years ago
(In reply to comment #35)
> I not only get:
...
> but I also get:
...

Thanks, but errors won't help - I know what the effect of the problem. It is steps to repeat that would be really valuable.

Comment 37

10 years ago
All I have to do is select any folder (inbox, etc.) and that first error message comes. Then when I double click a message, it comes again. When I switch or close tabs, it appears once again. When I close the window (not quit the app) to 'resolve' the problem, I get the second error message.
(Assignee)

Comment 38

10 years ago
(In reply to comment #37)
> All I have to do is select any folder (inbox, etc.) and that first error
> message comes. Then when I double click a message, it comes again. When I
> switch or close tabs, it appears once again. When I close the window (not quit
> the app) to 'resolve' the problem, I get the second error message.

Ok, so apply my workaround of selecting an item in the quick search menu which should make everything ok, then try your steps to repeat - as far as I can tell you shouldn't see your issue with those steps to repeat.

Comment 39

10 years ago
When I try to type a message subject in the quick search bar, then hit enter, "Loading Message..." appears in the status bar for a split second and nothing happens.
(Assignee)

Comment 40

10 years ago
Posted patch Proposed fixSplinter Review
I've been around the code several times not and I've still not found the cause of the bug although I know it happens.

This patch should hopefully be enough to work around it - if we get an undefined element in the constructor or in setSearchCriteriaText then we'll revert to the default as that seems the best thing to do. It works fine if I set the relevant quick-search-menupopup value in localstore.rdf to "undefined".
Attachment #396846 - Flags: review?(bugmail)

Comment 41

10 years ago
Ummm, this is gonna sound really stupid, but what do I do with the fix?
Comment on attachment 396846 [details] [diff] [review]
Proposed fix

No need to change the patch, but for future reference, you can make typeof look prettier by doing "typeof(var)" instead of "typeof var".  And also checking for undefined can be equivalently done via "var === undefined".  If you were just copying and pasting, then the notes are for the peanut gallery :)
Attachment #396846 - Flags: review?(bugmail) → review+
Uh, where "var" is an example of a horrible name for a variable.
(Assignee)

Comment 44

10 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/f9b555ac5d27
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: qawanted, testcase
Resolution: --- → FIXED

Comment 45

10 years ago
I replaced Applications/Thunderbird.app/Contents/MacOS/chrome/messenger.jar!/content/messenger/search.xml with the patch and the bug wasn't fixed at all. I also got this error message:

Error: not well-formed
Source File: jar:file:///Applications/Thunderbird.app/Contents/MacOS/chrome/messenger.jar!/content/messenger/search.xml
Line: 1, Column: 2
Source Code:
# HG changeset patch
(Assignee)

Comment 46

10 years ago
(In reply to comment #45)
> I replaced
> Applications/Thunderbird.app/Contents/MacOS/chrome/messenger.jar!/content/messenger/search.xml
> with the patch and the bug wasn't fixed at all. I also got this error message:

Replacing a file with a patch doesn't work. As the patch is already checked in, I suggest you wait for the nightly build which should be out in a few hours.

Comment 47

10 years ago
(In reply to comment #46)
> (In reply to comment #45)
> > I replaced
> > Applications/Thunderbird.app/Contents/MacOS/chrome/messenger.jar!/content/messenger/search.xml
> > with the patch and the bug wasn't fixed at all. I also got this error message:
> 
> Replacing a file with a patch doesn't work. As the patch is already checked in,
> I suggest you wait for the nightly build which should be out in a few hours.

I downloaded 3.0b4pre and the problem still persists.

Error: menuItems[0] is undefined
Source File: chrome://messenger/content/search.xml
Line: 297
(Assignee)

Comment 48

10 years ago
(In reply to comment #47)
> I downloaded 3.0b4pre and the problem still persists.
> 
> Error: menuItems[0] is undefined
> Source File: chrome://messenger/content/search.xml
> Line: 297

Please be patient. That is because the today's nightly hasn't been generated yet. You want the one which has a build id (help -> about) similar to:

Mozilla/5.0 (...) Gecko/20090827 Shredder/3.0b4pre

Comment 49

10 years ago
So today's nightly has the bug fixed. Thanks a ton. One question though, do I just hang on to the Shredder app or get rid of it once Thunderbird 3.0 or 3.0b4 is officially released?
(In reply to comment #49)
> So today's nightly has the bug fixed. Thanks a ton. One question though, do I
> just hang on to the Shredder app or get rid of it once Thunderbird 3.0 or 3.0b4
> is officially released?

You can choose both application share the same profile so if you feel like it youcan just install B4 when it goes out and then 3.0. We do need however a few braves to test nightlies and tell us if things get broken or not.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 513947
You need to log in before you can comment on or make changes to this bug.