Add-on description and "Add to Firefox" button are hidden by the screenshot when window is too narrow

VERIFIED FIXED in 5.0.8

Status

addons.mozilla.org Graveyard
Public Pages
--
minor
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: whimboo, Assigned: rdoherty)

Tracking

unspecified
5.0.8

Details

(URL)

Attachments

(2 attachments)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1pre) Gecko/20090715 Shiretoko/3.5.1pre ID:20090715031842

With the default width of the main browser window the add-ons description and the "Add to Firefox" button are partly hidden by the screenshot. I found this problem today while running Mozmill with the extension installation script which fails now.

I don't think that the text and the button should be moved behind the screenshot when the window is too narrow.
There was a push yesterday, right?
(In reply to comment #1)
> There was a push yesterday, right?

Yes; could you please attach a screenshot?  Thanks!
Is this a regression really? Looks to me like this wasn't introduced yesterday.
Severity: normal → minor
I don't have a chance to test with older AMO versions. The only thing I can say is that the Mozmill extension installation test fails since yesterday. It was fine when running the Smoketests on Wednesday (before the push).
(In reply to comment #4)
> Is this a regression really? Looks to me like this wasn't introduced yesterday.

It's not really a regression. The breaking Mozmill script is a result of the DOM changes on AMO with the latest push. I've updated the script and it works fine.

So it's only a problem on smaller widths which is e.g. for the default window size after the Firefox installation.
Keywords: regression
rdoherty offered to take this one, isn't he nice?
Assignee: nobody → rdoherty
Target Milestone: --- → 5.0.8
(Assignee)

Comment 8

9 years ago
Created attachment 390084 [details] [diff] [review]
v1

I have no idea how this works, but it does!
Attachment #390084 - Flags: review?(jbalogh)
Comment on attachment 390084 [details] [diff] [review]
v1

Way to show off your mad CSS skillz!

Only one thing:

>Index: site/app/webroot/css/amo2009/main-mozilla.css
>===================================================================
>--- site/app/webroot/css/amo2009/main-mozilla.css	(revision 30256)
>+++ site/app/webroot/css/amo2009/main-mozilla.css	(working copy)
>@@ -761,6 +761,9 @@
> 
> #addon .featured .secondary {
>     margin-bottom: 0;
>+    width: 230px;
>+    display: block;
>+    float: left;

It looks like this part can be removed.
Attachment #390084 - Flags: review?(jbalogh) → review+
(Assignee)

Comment 10

9 years ago
r30301 , extra css removed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Ryan where can I test it?
(In reply to comment #11)
> Ryan where can I test it?

Always at https://preview.addons.mozilla.org/en-US/firefox/
Thanks. Works fine. Marking verified.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.