CSS background color shown wrong in OSX

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: sbonzix, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

If I set the background of an element (for example a table cell) to #b9ba9f, Firefox in OS X shows #aaac8e instead (measured with ColorZilla and DigitalColor Meter). Haven't tested with other colors.
Doesn't happen in other browsers for Mac (tested on the same machine), nor in Windows (not even in Firefox - same release - for Win)

Reproducible: Always

Steps to Reproduce:
1. visit given URL with Firefox/OSX
2. measure colors with your prefered tool

Actual Results:  
Bug reproduced

Expected Results:  
It should show #b9ba9f, as specified
(Reporter)

Comment 1

9 years ago
Actually I did test another color, as it is possible to see in the test page I posted (http://sbonzix.info/2009/06/color-trouble-firefox-os-x/)

Comment 2

9 years ago
What are your settings for 'gfx.color_management.mode' in 'about:config' ?
(2 is the default)
(Reporter)

Comment 3

9 years ago
It was set on '1'. Switching it to '2' did the trick (now the colors show correctly). Thanks.
Does '2' mean 'false', i.e. no color management?

Comment 4

9 years ago
(In reply to comment #3)
> It was set on '1'. Switching it to '2' did the trick (now the colors show
> correctly). Thanks.
> Does '2' mean 'false', i.e. no color management?

'1' means color management for both images and css/html colors. '2' means color management for images with embedded color profiles only.

resolving as WorksForMe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

9 years ago
Oh, OK.

I had color management turned on in version 3 (the key was 'gfx.color_management.enabled' and the possible values were 'true' or 'false').

Then, the upgrade to 3.5 various betas probably kept that setting and translated it to '2' for "gfx.color_management.mode".
Is that possible? Because I don't remember changing it.

Thanks.

Comment 6

9 years ago
(In reply to comment #5)

> Then, the upgrade to 3.5 various betas probably kept that setting and
> translated it to '2' for "gfx.color_management.mode".
> Is that possible? Because I don't remember changing it.

Yes if you had the pref turned on in Fx 3, then that is the way it is converted.
I think.
You need to log in before you can comment on or make changes to this bug.