If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update the Jscoverage tool in the RE build machines

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: murali, Assigned: catlee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Please check out the latest jscoverage code from 
  svn co http://svn.siliconforks.com/jscoverage/trunk jscoverage
which has enhancements for auto storage as well as auto incrementing the javascript code coverage results.

This is an urgent request. Kindly accommodate this change ASAP.

Regards
Murali
(Reporter)

Updated

8 years ago
Blocks: 504642
(Assignee)

Updated

8 years ago
Component: Build Config → Release Engineering
Product: Firefox → mozilla.org
QA Contact: build.config → release
Version: unspecified → other
(In reply to comment #1)
> Please check out the latest jscoverage code from 
>   svn co http://svn.siliconforks.com/jscoverage/trunk jscoverage
> which has enhancements for auto storage as well as auto incrementing the
> javascript code coverage results.
We'll need to try this in staging before we start rolling it out to all the production slaves. Before we start that, can you clarify:
* Have you tested this in your ref-image based staging environment? 
* Are you asking us to pull tip-of-tree of that svn into production, or some specific release tag? (I want to make sure we can reproduce this on new VMs as they come online.)

> This is an urgent request. Kindly accommodate this change ASAP.
Err... Is this something new since our meeting Tuesday - can you clarify exactly what is the urgency here? Do I need to phone people who are traveling back from MV yesterday/today and off for weekend?

> Regards
> Murali
John.
(Reporter)

Comment 2

8 years ago
Yes I check out on reg-image based environment and compiled. The tip of the tree of the svn is what we need.

It is not that urgent call people on phone :)

But, I just wanted to make sure that the TIP I tested is not changed very much by the time it is checked out by RE. Please accommodate the svn checkout-compile-deploy at your convenience.
(Assignee)

Comment 3

8 years ago
Is revision 441 ok?
Assignee: nobody → catlee
(Reporter)

Comment 4

8 years ago
That is a good revision
(Assignee)

Comment 5

8 years ago
Created attachment 391334 [details] [diff] [review]
Adding jscoverage package
Attachment #391334 - Flags: review?(bhearsum)
Attachment #391334 - Flags: review?(bhearsum) → review+
Comment on attachment 391334 [details] [diff] [review]
Adding jscoverage package

Looks good to me.
(Assignee)

Comment 7

8 years ago
This is ready to be deployed next week.
(Assignee)

Comment 8

8 years ago
Comment on attachment 391334 [details] [diff] [review]
Adding jscoverage package

changeset:   42:84ccf3cd407f
Attachment #391334 - Flags: checked-in+
(Assignee)

Comment 9

8 years ago
This is getting rolled out via puppet now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.