Window.resizeBy method does not work.

VERIFIED FIXED in M6

Status

Core Graveyard
Tracking
P2
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: Prashant Desale, Assigned: davidm)

Tracking

Trunk
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Window.resizeBy mthod does not work.

Providing information to simulate the problem.

Product: Seamonkey.[apprunner]
Build Date: 04/13/99
Platform: PC [Windows-95]

Steps to Reproduce:
1] Please copy the code I'm providing. Save as HTML file.
2] Open this HTML file in apprunner.


Expected Results: As soon as you open this HTML file, window should  start
shrinking from bottom-right corner. Window should shrink by 2 pixels, and it
should happen 100 times in loop. After some time, you should be able to see
small window. During shrinking you should be able to see the shrinking process.

Actual Results: Window does not shrink.


Code:

<html>
<head>
<title>Window Resize</title>
</head>
<body >
<script>
<!--
for ( i = 0; i < 200; i=i+2) {
self.resizeBy(-2,-2)
}
//-->
</script>
</body>
</html>
(Reporter)

Updated

19 years ago
Summary: Window.resizeBy mthod does not work. → Window.resizeBy method does not work.
(Reporter)

Comment 1

19 years ago
window.resizeTo method also does not work. I'm not entering seperate bug for
that, since this is related to this bug.

Updated

19 years ago
Assignee: vidur → joki

Updated

19 years ago
Assignee: joki → trudelle

Comment 2

19 years ago
This is also part of that whole 'apprunner doesn't provide a nsIBrowserWindow
interface to Gecko' problem.  I think there's a bug for this somewhere out
there already.  Giving to apprunner guys.

Updated

19 years ago
Assignee: trudelle → don
Component: DOM Level 0 → Apprunner

Comment 3

19 years ago
don, is this yours too?

Updated

19 years ago
Assignee: don → davidm
Priority: P3 → P2
Target Milestone: M6

Comment 4

19 years ago
Re-assigned to davidm.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Hardware: PC → All
(Assignee)

Comment 5

19 years ago
m6 assign. Aother DOM object to impliment
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
Working ( 5/6/99 Mac build) as a result of some changes hyatt made
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Tested both methods resizeBy() and resizeTo(). both are working fine now.
Marking as verified.

Comment 8

19 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.