If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Illegal Instruction Call when starting fennec on Diablo/N810

VERIFIED DUPLICATE of bug 503570

Status

Fennec Graveyard
General
--
critical
VERIFIED DUPLICATE of bug 503570
8 years ago
7 years ago

People

(Reporter: jbos, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009060308 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: Fennec/Mozilla-Central changeset:   30336:c40a68c662da

I using the resent mozilla central/browser-mobile version to compile fennec in an Scratchbox-Maemo-Diablo-Arml Target. When I start fennec on an N810 Device it cause an illegal Instruction call, the ui is shortly visible.

I use the following scratchbox setup:

    cs2007q3-glibc2.5-arm6  
    Architecture:     arm 
    Sub-architecture: arm 
    C-library:        glibc
    Devkits:          cputransp debian-etch maemo3-tools perl 
    CPU-transparency: /scratchbox/devkits/cputransp/bin/qemu-arm-cvs-m

    qemu-arm-cvs-m Version is: 0.9.0-cvs

I use the following mozconfig:
    
    export LDFLAGS="-Wl,-rpath-link,$PWD/dist/bin/:/usr/lib:/lib"

    mk_add_options MOZ_BUILD_PROJECTS="xulrunner mobile"
    mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../mobilebase

    ac_add_options --disable-tests
    ac_add_options --disable-javaxpcom

    ac_add_app_options xulrunner --with-arm-kuser
    ac_add_app_options xulrunner --enable-application=xulrunner

    ac_add_app_options mobile --enable-application=mobile
    ac_add_app_options mobile --with-libxul-sdk=../xulrunner/dist

It works fine with changeset: 29844:b1b2f9a366ca
It does not work with changeset: 30336:c40a68c662da




Reproducible: Always

Steps to Reproduce:
1.Compile fennec in an Diablo-Arml Target
2.Create a Mobile Package ..../mobile># make package
3.Copy the tar.bz2 on the N810 Device
4.'Install' fennec on the N810 Device
5.Try to start fennec
Actual Results:  
Crash with Illegal instruction

Expected Results:  
Fennec start correctly
dup of bug 503570 ?
(Reporter)

Comment 2

8 years ago
Thanks, the patch fixed the issue for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503570
verified with nightly build 08/13/2009
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.