Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 504773 - Firefox does not insert saved password without Username (blank Username)
: Firefox does not insert saved password without Username (blank Username)
Product: Firefox
Classification: Client Software
Component: Security (show other bugs)
: 3.5 Branch
: x86 Windows XP
: -- major with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2009-07-17 03:04 PDT by Chris
Modified: 2011-09-05 07:17 PDT (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Chris 2009-07-17 03:04:58 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20090715 Firefox/3.5.1

Https-Sites, like the main page from Fritz-Boxes ( or access over internet), do not display the saved password any longer. (Since FF 3.5, earlyer Versions did!)

The only differenz seems to the other passwords seems to be, that these passwords have no Username in the list password. (Only https-Site + password. Username is blank)

Reproducible: Always
Comment 1 Atlanx 2009-08-10 04:10:10 PDT
I can confirm this problem with my Fritz!Box and Firefox 3.5.x, too.

After update from Firefox 3.0.x to 3.5.x Firefox does not input the saved password in the password field of the login-page any more.

In someone told me that in Firefox 2.x there was probably the same problem but got fixed in 3.0.x:
Only as commentary: same bug in FF 2.0, fixed by 3.0 as you said.


My System: 
Firefox 3.5.2
WinXP+SP3 German
AVM FRITZ!Box Fon WLAN 7270 (Firmware-Version 54.04.76)!Box_Fon_WLAN_7270
Comment 2 myzyxel 2009-08-21 05:18:29 PDT
The same issue exists for many Zyxel routers. 
There is only a password field, no username, and the password field is auto-filled with the factory default password.

Bug 327977 talks about how the password manager no longer overwrites existing data.

These routers are a case where an exception to the rule would be useful.
Comment 3 Atlanx 2011-05-03 02:53:05 PDT
- Two user confirms
- Four votes for fixing this


 Why the Bug has still status: UNCONFIRMED ????
Comment 4 Vlad [QA] 2011-05-05 07:17:35 PDT
Verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110504 Firefox/6.0a1
Comment 5 myzyxel 2011-05-05 07:56:56 PDT
Checked against latest nightly:
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110505 Firefox/6.0a1

Bug is NOT resolved/fixed, password manager does not overwrite field data.
Comment 6 spamadresse12345 2011-09-05 07:17:16 PDT
Impressive, how this is still not fixed. Just wasted ~30 minutes on my WRT120N and IIRC it worked in previous versions, but not with v7.0. Awesome.

Note You need to log in before you can comment on or make changes to this bug.