Scrolling performance drops significantly after I open a drop down form menu (Select Input)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: clash_idol, Unassigned)

Tracking

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 FirePHP/0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 FirePHP/0.3

First of all I didn't have this problem in FireFox 3.0.

It happens everytime I open a dropdown menu in a form on a page, I mean the <SELECT> html element, before I open the menu everything's fine, I scroll up and down and CPU Usage is normal, after I open a drop down menu no matter if I change it, keep it open or I close it instantly FireFox will have a hard time scrolling up and down in that page. It almost max out my CPU Usage when I scroll up or down. There's no extreme CPU usage if I don't scroll up and down and everything will be back to normal if I reload the page, but the story repeats itself again if I open a dropdown menu.

P.S: I've upgraded to FireFox 3.5.1 today and the problem still remains.

Reproducible: Always

Steps to Reproduce:
1.View a page that has one or more dropdown menu (SELECT HTML ELEMENT)
2.Open one of drop down menus no matter if I change, close or keep it open
3.FireFox will have a hard time scrolling up and down in that page.
Actual Results:  
Scrolling up and down in the page that I have opened a drop down menu on it max out my CPU usage.

Expected Results:  
I expected no performance drop after I open a Dropdown (SELECT HTML ELEMENT) on a page of course!

I am using FireFox 3.5.1 (same problem was in FireFox 3.5), I am using the Default theme, I have "Web Developer", "FireBug" and "FirePHP" add-ons installed. And I am using firefox on primary display on a Dual-Display mac machine (I donno if it can be important).
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090716 Minefield/3.6a1pre

I have no scroll performance problem after using the select boxes above.
Do you see the same with a new profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 3.5 Branch
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is far gone. If the reporter can still see this issue, Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Then please remove the closeme tag in the whiteboard, mark the bug against the proper version and comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.