automatically updated firefox 3.5.1 and all addons are lost

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
10 years ago
8 years ago

People

(Reporter: ph.tchaa, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Firefox was updated to 3.5.1 by itself from 3.5. After I restarted it, it didn't show up the compatibility of the addons (something like a install wizard should appears). And then all addons I have before are lost.
including:
firebug
tagkit
skipscreen
...

Reproducible: Didn't try

Steps to Reproduce:
reproducing it is difficult, since it involves installing the 3.5 version and letting it automatically update.
Please attach the following files from your profile directory
http://support.mozilla.com/en-US/kb/Profiles

extensions.cache
extensions.ini
extensions.rdf

and if present the extensions.log

Might be an app update or add-ons manager bug. Moving over to add-ons manager to first find out what happened to the extensions
Component: Installer → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: installer → add-ons.manager
Version: unspecified → 1.9.1 Branch
Without the information requested in comment 1 we can't really evaluate this bug report further. Closing as incomplete. Ross, please reopen if you can provide the information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

10 years ago
Created attachment 393149 [details]
extensions.cache for diagnosis

as requested. Thanks
(Reporter)

Comment 4

10 years ago
Created attachment 393150 [details]
extensions.ini for diagnosis
(Reporter)

Comment 5

10 years ago
Created attachment 393151 [details]
extensions.rdf for diagnosis
(Reporter)

Updated

10 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Attachment #393149 - Attachment mime type: application/octet-stream → text/plain
Attachment #393150 - Attachment mime type: application/octet-stream → text/plain
Attachment #393151 - Attachment mime type: application/rdf+xml → text/plain
What add-ons are listed when you look in the add-ons manager?
(Reporter)

Comment 7

10 years ago
I now have firebug 1.4.2 and hong kong toolbar 3.3.9.0, which i installed after the update.
A lot of code has been changed since the bug has been filed. I don't think it is useful to keep this report open. File a new bug if you can still reproduce it with Firefox 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.