Appearance of HTML-Mails doesn't fit before and after sending in some cases

RESOLVED DUPLICATE of bug 119594

Status

RESOLVED DUPLICATE of bug 119594
9 years ago
7 years ago

People

(Reporter: Nomis101, Unassigned)

Tracking

({testcase})

Trunk
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; de-de) AppleWebKit/530.19.2 (KHTML, like Gecko) Version/4.0.2 Safari/530.19
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

In some cases the appearance of a composed HTML-Mail doesn't look like it should. The appearance looks different before and after sending. 
In the screenshot you can see an example, I used the Apple Mail Stationery "Flower.mailstationery" for this test. After sending the background of the mail is missing. Its missing if I open the received mail in Thunderbird and its also missing if I open the mail on the ISPs website.
For the same HTML code this happens every time.

Reproducible: Always

Steps to Reproduce:
1. Open the compose window
2. Go to "Insert" --> "HTML..." and paste an HTML code (with background pictures and so on)
3. If the mail looks good send it
4. Look how the sended mail looks like



For my test I used the following HTML code (from the Apple Mail Stationery, modified):

<html>
<head>
<title>Flower</title>
</head>
<body style="background:url(file:///Resources/bg_pattern.jpg) 50% 0;margin:0;padding:0">
<div style="background:url(file:///Resources/bg_pattern.jpg) 50% 0;">
	<table width="575" border="0" cellspacing="0" cellpadding="0" class="email-body-wrap" id="email-body" align="center">
		<tr>
			<td width="20" background="file:///Resources/bg_pattern.jpg">&nbsp;</td>
			<td width="535"><table width="535" border="0" cellpadding="0" cellspacing="0">
					<tr>
						<td width="535" height="85" colspan="4" background="file:///Resources/bg_pattern.jpg" class="top">&nbsp;</td>
					</tr>
					<tr>
						<td width="535" colspan="4" class="top"><img src="file:///Resources/top.jpg" width="535" height="24"></td>
					</tr>
					<tr>
						<td width="183" valign="top" background="file:///Resources/flowerstem.jpg" class="top-bg"><img src="file:///Resources/flower.jpg" width="183" height="341"></td>
						<td width="352" valign="top" background="file:///Resources/bg_letter.jpg" class="top-bg"><table width="352" border="0" cellpadding="0" cellspacing="0">
								<tr>
									<td height="62" colspan="3">&nbsp;</td>
								</tr>
								<tr>
									<td align="left" id="title"><div class="body-title" id="body-title"><font face="Georgia" color="#f38c50" style="font-size:83px"><span contenteditable="true" apple-content-name="title" style="display:block;width:332px">Sorry</span></font></div></td>
									<td width="20">&nbsp;</td>
								</tr>
								<tr>
									<td height="50" colspan="3">&nbsp;</td>
								</tr>
								<tr>
									<td width="332" align="left"><font color="#847354" face="Georgia" style="font-size:15px; text-align:left;"><span contenteditable="true" apple-content-name="body" style="display:block;width:332px">
										<div class="body-content" id="body-content" style="line-height:1.5;">
											Eliquatuero dip eros nusan vent etlam, conum zrit la facillum initit doloreet ullame tuero od tet lor adit commod tummy. Eliquatuero dip eros nusan vent etlam,conum zrit la facillum initit doloreet ullame tuero od tet lor adit commod tummy.<div><br></div>
											Sincerely,<br>Drew<div><br></div>
										</div></span>
									</font></td>
									<td width="20">&nbsp;</td>
								</tr>
								<tr>
									<td height="115" colspan="3">&nbsp;</td>
								</tr>
							</table></td>
					</tr>
					<tr>
						<td width="535" colspan="2" class="bottom-bg"><div align="center"><img src="file:///Resources/bottom.jpg" width="535" height="59" alt="" style="display:block;" /></div></td>
					</tr>
					<tr>
						<td width="535" height="57" colspan="2" background="file:///Resources/bg_pattern.jpg" class="bottom-bg">&nbsp;</td>
					</tr>
				</table></td>
			<td width="20" background="file:///Resources/bg_pattern.jpg">&nbsp;</td>
		</tr>
	</table>
</div>
</body>
</html>



The only displayed pictures in the sended mail are flower.jpg, top.jpg, bottom.jpg. All other pictures are missing (after sending).
(Reporter)

Comment 1

9 years ago
Created attachment 389301 [details]
Screenshot

HTML mail (before sending on the left, after sending on the right)
What's the source of the actual message received?
(Reporter)

Comment 3

9 years ago
Created attachment 389303 [details]
Source of received message

(In reply to comment #2)
> What's the source of the actual message received?

This is the source of the received message.

Comment 4

9 years ago
Styled backgrounds have always been a problems for TB
The file references should have been converted to CID's but were not.
I'm sure this is a dup of one of my 5-8 year old bugs.
(I'll look it up, but chances are this will never be fixed until a complete re-write of Libmime and a new composer/editor)
The only way  know of to get a background image in a table or div is to use a data url.

Comment 5

9 years ago
xref bug 116867
Fixed by the fact that styled backgrounds are not wanted/supported.
The fact that you (and I) might want to use them seems irrelevant.
Confirmed here

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091022 Lightning/1.0pre Shredder/3.0pre ID:20091022031603

Probably a dupe.
Status: UNCONFIRMED → NEW
Component: General → Message Reader UI
Ever confirmed: true
Keywords: testcase
QA Contact: general → message-reader
Version: unspecified → Trunk

Updated

9 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: dupeme

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 119594
You need to log in before you can comment on or make changes to this bug.