location bar is not editable after new tabs created with ctrl+T or add tab ('+') button

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: dpeters, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

the location bar / address bar is no longer available for direct editing after a new tab is created. Bookmarks and links still work, but direct manipulation of address string is blocked :(

Reproducible: Always

Steps to Reproduce:
1.open browser, enter url
2.use ctrl+t to create new tab (creates new tab with about:blank)
3.go to new tab and enter url (fails)
4.return to original tab and edit url (fails)
Actual Results:  
after a new tab is created the address bar (location bar) is no longer available for editing.

Expected Results:  
address bar should available for editing on all tabs

address bar should not be blocked for editing. maybe related to auto-complete, or tab focus issues that are already reported.
I'm calling this a major feature because ff3.5 is useless to me as a developer until this is corrected.

here is my current build info:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
I don't see this on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729).

Can you see this problem in Safe Mode ( http://kb.mozillazine.org/Safe_Mode )?  If so, do you see it with a new profile ( http://kb.mozillazine.org/Profile_Manager )?
(Reporter)

Comment 2

10 years ago
Kyle, I'm sorry I reverted back to 3.0.11 so I could get some work done today, though I will test further soon.

But... based on your details:
* maybe the fix is in 3.5.1, vs 3.5, or 
* maybe internal to the gecko build (20090624 vs 20090715)

Either way if it is fixed now I'll check it out again as soon as I have time. Looks like 3.5.1 was promoted 7/15 - unsure why my auto-update hadn't picked it up.

Comment 3

10 years ago
The gecko build just reflects the date the new version was built. This really sounds like something caused by an addon, so safe mode or a new profile should tell us that (use 3.5.1 or later of course :)
Version: unspecified → 3.5 Branch

Comment 4

10 years ago
I also cannot reproduce this. I bet it is an add-on problem.
wfm too
resolving, but feel free to reopen if you can reproduce this in safe mode and with a new profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.