@font-face applies with sensible delay even when fonts are explicitly cached

RESOLVED DUPLICATE of bug 468568

Status

()

RESOLVED DUPLICATE of bug 468568
9 years ago
9 years ago

People

(Reporter: fin.bub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; uk; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; uk; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

My server sends expire headers for every .otf/.ttf and Firefox caches them (no GET captured), but content is displayed 'using the best CSS fallback' for a few seconds for an EVERY page I load. I't's an quite ugly effect! 

Reproducible: Always

Steps to Reproduce:
1.create a page using font-face and be shure fonts are caching
2.open it twice
Actual Results:  
I see a delay in changing the font from fallbacked to custom

Expected Results:  
Delay on first load, no delay in next
looks like a dupe of bug 468568 ( via bug 502494)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468568
You need to log in before you can comment on or make changes to this bug.