Import Wizard does not include an option to import .json files

RESOLVED WONTFIX

Status

()

Firefox
Migration
P3
enhancement
RESOLVED WONTFIX
9 years ago
6 years ago

People

(Reporter: Martin, Assigned: Dennis)

Tracking

({student-project})

Trunk
Future
student-project
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090718 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090718 Minefield/3.6a1pre

First time you launch Firefox, the Import Wizard pop up. You can chose to import bookmarks from Internet Explorer or a HTML-file. Well that is good, but why can you not import backup-file from Firefox itself, i.e .json? Yeah sure this can be done manually from Bookmark library, but would be easier to import on first launch. Especially when it's possible to import from IE and HTML.

Reproducible: Always

Steps to Reproduce:
1. Do a fresh install of Firefox.
2. Import Wizard popups
3. You are not able to import .json-files.
Actual Results:  
You are not able to import .json from the Import Wizard

Expected Results:  
You should be able to import json-bookmarks from the Import Wizard.
(Reporter)

Updated

9 years ago
OS: Windows NT → Windows 7

Comment 1

9 years ago
Since we have code that does this already I assume this is mostly a UI change? If in fact we want to implement this?

Updated

9 years ago
Status: UNCONFIRMED → NEW
Component: Bookmarks & History → Migration
Ever confirmed: true
OS: Windows 7 → All
QA Contact: bookmarks → migration
Hardware: x86_64 → All
(Reporter)

Comment 2

9 years ago
Yeah, just to make it easier to import backuped bookmarks after a reinstall or format. I'd just like an option in the Import Wizard to import json-files so I can do it using the Wizard at the first run. But it is indeed possible to do it manually from the Bookmark Library. Though I think since the Wizard appears after a fresh install anyway, it can as well include json as option since that is actually Firefox's way to backup bookmarks.
I format my computer quite often myself and realized that it would save me a minute each time to be able to restore json-backups using the Wizard that automatically pops up on first run anyway.
We should definitely take this if someone wants to fix it.
Priority: -- → P3
Whiteboard: [good first bug]
Target Milestone: --- → Future
(Assignee)

Comment 4

8 years ago
I want to take this. Will propose a patch soon...
Assignee: nobody → dennis.brutski
Keywords: student-project
Version: unspecified → Trunk
(Assignee)

Comment 5

8 years ago
Created attachment 422777 [details] [diff] [review]
patch for bug 505109
Attachment #422777 - Flags: review?(mconnor)
Comment on attachment 422777 [details] [diff] [review]
patch for bug 505109

I am no longer actively working on Firefox, please find another reviewer.
Attachment #422777 - Flags: review?(mconnor)
Unlikely.

The HTML option was removed from the wizard a while ago.  The use cases for this option should be covered by a Firefox Sync "migrator" option, but that's another bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.