Closed Bug 505214 Opened 11 years ago Closed 11 years ago

Implement Workspaces

Categories

(Firefox :: Tabbed Browser, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: glen.84, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

The basic idea of tab grouping has been invented and re-invented a hundred times. Examples include:

* Tabgroups-Plus (https://addons.mozilla.org/en-US/firefox/addon/9187)
* TabGroups Manager (https://addons.mozilla.org/en-US/firefox/addon/10254)
* Tab Groups (http://paranoid-androids.com/tabgroups/index.htm)
* ... and various other theoretical ideas during the recent Mozilla Labs Design Challenge (http://design-challenge.mozilla.com/summer09/index.html)

Due to the complexity of the feature, existing extensions lack stability and completeness. Since many users could benefit from such functionality, I thought that it may be best to build this into Firefox itself (hence the RFE).

The idea is to keep it as simple and out-of-the-way as possible.

The term "workspaces" is used by the OmniWeb browser (http://www.omnigroup.com/applications/omniweb/), and its use would allow the "group" term to be reserved for use in grouping tabs by domain, origin, etc. within a workspace.

The following is a list of some of the behaviour and UI features that could/should be supported. (See the attached mockups first.)

- The Workspaces Bar should be hidden by default to avoid UI clutter and user confusion (can be shown using the "Show Workspaces Bar" option in the Workspaces Menu, by using the View -> Toolbars menu, or by using a keyboard shortcut).

- The Workspaces Bar is used for the management of workspaces, but may often be closed to increase the user's screen real estate. The Workspaces Menu would then be used due to its compactness.

- Workspaces can be re-ordered in the Workspaces Bar using drag & drop (the same way tabs are re-ordered).

- Tabs (as well as links) can be dragged & dropped onto existing workspace buttons.

- Workspaces should be persisted across sessions (session restore, etc.).

- It should be possible to prioritize the loading of the current workspace when restoring a session/starting Firefox. Other workspaces could load slowly in the background and get priority when selected (or not load until the workspace is opened [pref.]). Individual tabs should be loaded using strategies similar to the ones described in bug #496458.

- Right clicking a workspace button should show a menu with the following options: New Workspace, Reload All Tabs in Workspace, Bookmark All Tabs in Workspace, Rename Workspace, Save Workspace, Close Workspace.

- "Move To -> {list of workspaces} + New Workspace" should be added to the right-click menu of tabs.

- "Open Link in Workspace -> {list of workspaces} + New Workspace" should be added to the right-click menu of links.

- Preference should dictate in which workspace to load external links (currently selected or default workspace).

- "List all tabs" drop down menu on the right of the tab bar should show all tabs in the currently selected workspace. (Tooltip could be changed to "List all tabs in workspace")

- Preference should dictate if a tab overview page or the currently selected tab in a workspace should be displayed when a workspace is opened.

- Prefs to show number of tabs in workspace next to the workspace name (one pref. for bar, one for menu). Number of tabs will show in the tooltip regardless.

- Pref. to keep workspace open when it contains no tabs.

While this may be similar to bug #453984, I feel that this has a larger scope and includes a lot more detail.

The details above are somewhat unstructured, however if this bug receives attention, I will organise things on request.

Reproducible: Always
Attached image Workspaces Menu
Attached image Workspaces Bar
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Tabs in tabs is not especially good UI.  This is already possible with multiple windows, and avoids creating yet another layer of window/tab mangement.

This should definitely remain in extension space.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Mike,

The tabs really have nothing to do with the proposal, the proposal is about workspaces. The UI can be implemented in any way you want:

* A workspaces menu to the right of the tab bar, as seen in the screenshot – "Show Workspaces Bar" could be replaced with "Manage Workspaces" which would open a dialog with options to add/remove/rename/re-order workspaces.
* A "Workspaces" menu next to the other main menus, with a similar menu option to manage workspaces.
* A sidebar.
* Even using existing tabs and being able to drop one tab on another to form a group (clicking the favicon might show the list of tabs in each group).

If I have two windows open, close both, and then start Firefox, I only see one window, so I don't see how this is possible using windows. It also makes sense to keep everything together, why have 5 or 10 Firefox windows open when you can just have 1.

As far as I can tell (judging from existing buggy attempts), this is too difficult to implement perfectly at the extension level. I wish Mozilla could release "official extensions" for things like this, or at least provide a reference implementation of some sort.
I recognize there's lots of ways to do this.  I've seen many of them, as extensions, and in another applications, and trying to insert another layer of document management usually just ends up in having a really heavy UI.  There's Windows, on many platforms there's multiple OS-level workspaces, and there's tabs.  Having something in between windows and tabs in the hierarchy just adds more complexity, and doesn't really gain enough to justify the additional overhead.
Did you discuss this with other Mozilla staff (or the community, since it's an open source project), or make the decision on your own?

What is the purpose of things like the Mozilla Labs Design Challenge of Summer 09(1) and blog posts(2) from Mozilla developers like Aza Raskin, if they are never going to be implemented?

Many of the design challenge entries (including most of the "Best in Class" "winners") included mechanisms for grouping tabs.

The UI does not have to be heavy, and in fact can and should be optional (users who don't use more than 5 or 10 tabs should not see additional UI elements). Quite honestly, the UI I describe in point 1 of my previous comment is *extremely* light. Have a look at the UI used by the OmniWeb browser(3), which is basically the same thing (with a different workspaces menu location).

Please reconsider.

(1) http://design-challenge.mozilla.com/summer09/index.html
(2) http://www.azarask.in/blog/post/firefoxnext-tabs-on-the-side/
(3) http://s3.amazonaws.com/downloads.omnigroup.com/software/MacOSX/movies/OmniWeb/Workspaces.mov
Glen,

An extension: TabGroups Manager, that achieves just this, is readily available for you.

https://addons.mozilla.org/en-US/firefox/addon/10254

Cheers,
Aaron
It's an open source project, but not a democracy.  It's been discussed before, but it's basically tacking another concept in between windows and tabs, instead of redefining the tab layer, which I think is vastly preferable. 

As for the "what's the point?" questions, the point is to explore alternatives until we find one that works, not to harvest a bunch of ideas that we'll definitely do.  I don't think this specific idea is useful or right for Firefox, so I'm saying no to this, as module owner.  I think there are better ways of implementing grouping, and we're going to explore those.
(In reply to comment #7)
> Glen,
> 
> An extension: TabGroups Manager, that achieves just this, is readily available
> for you.
> 
> https://addons.mozilla.org/en-US/firefox/addon/10254
> 
> Cheers,
> Aaron

Yes, I'm using that extension. Not perfect, but I guess I have no other options.

Thanks.
http://www.azarask.in/blog/post/tabcandy/

... no comment.
You need to log in before you can comment on or make changes to this bug.