All users were logged out of Bugzilla on October 13th, 2018

Proxy|Prefs (manual) - default port should be blank, ! "0"

RESOLVED FIXED in mozilla1.8beta1

Status

()

P3
minor
RESOLVED FIXED
18 years ago
14 years ago

People

(Reporter: mpt, Assigned: darin.moz)

Tracking

({polish})

Trunk
mozilla1.8beta1
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: checklinux checkwin)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

18 years ago
Build: 2000082608, MacOS 9.0

To reproduce:
* Do a clean install of Mozilla.
* Start Mozilla.
* Open the Preferences dialog, and navigate to Advanced > Proxies.

What you see:
* In the `Manual proxy configuration' section, the port number field for each
  proxy is set to `0'.

What was expected:
* The port number fields should be blank until I enter values into them.
tever, d'you know which engineer would fix this --or would that be you, matt?
thx.
Keywords: nsbeta3, polish
QA Contact: sairuh → tever
Hardware: Macintosh → All

Comment 2

18 years ago
i think we did this because it needed to be a number at sometime.
Will fix in all.js
Status: NEW → ASSIGNED

Comment 3

18 years ago
Nav triage team: [nsbeta3-]
Whiteboard: [nsbeta3-]

Comment 5

18 years ago
bah. this will collide w/ my prefs reorg.

r=timeless, if you get it in before i land my changes. if not this patch earns 
instant bitrot.
Keywords: nsbeta3 → approval, patch
OS: Mac System 8.5 → All
Whiteboard: [nsbeta3-]

Comment 6

18 years ago
ack! this is the WRONG way to fix this problem. You're changing the types of
these prefs to strings from integers. Please fix the pref PANEL not the prefs
themselves

Comment 7

18 years ago
Yeah, we should change the display of 0 to blank in the panel.

Nobody's really going to run a proxy server off port 0 are they. Adding support
for port 0 would be an RFE anyhow, because Communicator and Mozilla both treat
port number 0 as "off".

Updated

18 years ago
Summary: Default manual proxy port numbers should be blank, not 0 → Proxy|Prefs (manual) - default port should be blank, ! "0"
->samir, moz0.9.5. needs updated patch.
Assignee: matt → sgehani
Status: ASSIGNED → NEW
Keywords: review
QA Contact: tever → sairuh
Target Milestone: --- → mozilla0.9.5
Keywords: approval, patch, review

Comment 9

17 years ago
Mass-moving lower-priority 0.9.5 bugs off to 0.9.6 to make way for remaining
0.9.4/eMojo bugs, and MachV planning, performance and feature work. If you
disagree with any of these targets, please let me know.
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 10

17 years ago
Created attachment 52403 [details] [diff] [review]
Use |null|, not |0| or |""|

Comment 11

17 years ago
Supplied patch should be what we're after. I wonder if perhaps we should set the
default http cache port to 8080, not null?
Keywords: patch

Comment 12

17 years ago
Comment on attachment 52403 [details] [diff] [review]
Use |null|, not |0| or |""|

I don't see how this fixes the bug. the integer value of the pref should still be "0". What is the pref type after we change this value? a string?

Comment 13

17 years ago
And how can we achieve that? I'm not sure I know a code to say, "empty integer."
 I didn't observe any problems with the |null| setting.

Comment 14

17 years ago
Once we get a reviewed patch I can check it in.  
Keywords: patch → helpwanted
Target Milestone: mozilla0.9.6 → Future

Comment 15

14 years ago
I'm not sure whether this should be fixed.

I read the zeroes in the default prefs as indicating that if I don't
change the port, my settings won't work.  (No proxy is going to be
listening to port zero.)  If there were just blank spaces in the default
prefs, I might assume that (as in some telnet clients) if I didn't enter
a port a reasonable default would be silently assumed.  For the HTTP
proxy, for example, I might leave the port field blank assuming that I
didn't have to enter '8080' if I had only been told the hostname of my
HTTP proxy.

Anyway, seeing a little zero now and then does not bother me so much.
If there is any reason that this should be changed, I will gladly play
around with the interface code.

Comment 16

14 years ago
Adding myself to the CC list.  Sorry for the spam

Comment 17

14 years ago
-> networking
Assignee: samir_bugzilla → darin
Component: Preferences → Networking
QA Contact: bugzilla → benc

Updated

14 years ago
Attachment #24345 - Attachment is obsolete: true

Updated

14 years ago
Depends on: 257758

Comment 18

14 years ago
Fixed via bug 257758.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: Future → mozilla1.8beta

Comment 19

14 years ago
V/fixed:
1.8b1, Mac OS X
Jonathan: I don't think your objection is relevant here. People either set up
their proxies or someone gives them config info.

In either case, the configuration info would contain a hostname or port.
Keywords: helpwanted
Whiteboard: checklinux checkwin

Comment 20

14 years ago
(In reply to comment #19)

Yes, you're right.

I don't know how I stumbled onto this bug, but I had decided that this was
something I could fix; then I examined the problem more closely and decided
fixing it wouldn't accomplish anything (i.e. I didn't see any costs or benefits
from the fix).  Sorry for my confusing comment.  In my use of Mozilla and
Firefox, this bug doesn't affect me at all.
You need to log in before you can comment on or make changes to this bug.