Consider stripping trailing periods in add-on names when using them in user messages

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
--
minor
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: krupa, Assigned: osunick)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 389493 [details]
redundant full stop

steps to reproduce:
1.Log in to your AMO account
2.Go to https://preview.addons.mozilla.org/en-US/firefox/addon/9412
3.Select a collection from the drop-down list under "Add to a collection" section.
4.Click "Publish"
5.Notice the success message

observed behavior:
If the add-on name ends with a full stop,then the success message also has this full stop in the middle of the sentence.(see attached image)
The name of this add-on is "Infoaxe: Full Text Web History Search synchronized between Firefox, IE on multiple computers.", so that period in the middle of the sentence is not our doing
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Here the expectation was that trailing periods would be stripped off the add-on name when we use it in user messages.I am reopening for your consideration..but if you think its still invalid,please mark it so.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: Redundant full stop in success message on publishing add-on to a collection → Consider stripping trailing periods in add-on names when using them in user messages
Dupe of bug 503091? I know, that bug is about *leading* characters, but I think this is the same type of request.
The eventual solution for bug 503091 could probably be applied here but I don't think it's a dupe, at least in spirit.  This bug is more of a social problem, that people don't understand the difference between titles and descriptions.

CCing Mr. Win for a decision.
Assignee: nobody → nnguyen
Target Milestone: 5.0.8 → ---

Comment 5

9 years ago
There might be cases where we do not want to remove the trailing period from an add-on name.  For example, an add-on name might happen to end with “U.S.A.”  I have not bothered to find an actual example, though.  Just my two cents.
(Assignee)

Comment 6

8 years ago
WONTFIXED.  this is easy enough for users to fix themselves if they want.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.