xpti.dat, xptitemp.dat creation in r/o space

VERIFIED DUPLICATE of bug 42184

Status

Core Graveyard
Installer: XPInstall Engine
P3
critical
VERIFIED DUPLICATE of bug 42184
18 years ago
2 years ago

People

(Reporter: wicki, Assigned: dveditz)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
For Solaris and Linux m17 it tries to create the files xpti.dat and xptitemp.dat
in the components dir: 
open64("{...}/m17/components/xptitemp.dat", O_WRONLY|O_CREAT|O_TRUNC, 0666)
Err#30 EROFS
open("{...}/m17/components/xpti.dat", O_WRONLY|O_CREAT|O_TRUNC|O_EXCL, 0644)
Err#30 EROFS

same with strace on Linux (only the error n# is different, because it's
not NFS r/o). IT SIMPLY DOESN'T START!

	wicki

Comment 1

18 years ago
updating component and setting defualt owner.
Assignee: asa → dveditz
Component: Browser-General → Installer: XPInstall Engine
QA Contact: doronr → jimmylee
(Assignee)

Comment 2

18 years ago
Run once with write privileges to register necessary components, or build and 
use a distribution that comes with these pre-built files. Duplicate of 42184

*** This bug has been marked as a duplicate of 42184 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.