Open Bug 505348 Opened 11 years ago Updated 1 year ago

DLink Router- Fails to access files (i.e. installing firmware and settings files)

Categories

(Firefox :: File Handling, defect)

3.5 Branch
x86
Windows XP
defect
Not set

Tracking

()

UNCONFIRMED

People

(Reporter: prishantha, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

For DLink Router DSL-2640B (and possibly others as well), after logging into the router's webpage (the usual 192.168.1.1) and going to the firmware page to update it using a file acquired from the manufacturer's website, upon selecting the file then clicking Update, an error message appears from the router's webpage saying 'Please select a valid filename'. Several hours of tech support led me to realize that they are extremely unacquainted with this sort of issue (having already attempted the power off and reset button tricks). So, I tried opening the router's webpage with Internet Explorer 8, and using files to update the router (both the firmware update [which, technically, was reinstallation of the same firmware] and the loading of saved settings configurations), which worked perfectly fine. Note: Only extensions on my Firefox are Adobe DLM and Java Quickstarter, so I'm pretty sure it's not caused by anything I've added to Firefox.

Reproducible: Always

Steps to Reproduce:
1. Connect to router's webpage (192.168.1.1)
2. Go to Firmware Update page
3. Select Firmware file and click Update
Actual Results:  
"The page at http://192.168.1.1 says:
Please enter a valid filename"

Expected Results:  
Should have loaded the selected file into the router (~1-2 minute process; in Internet Explorer, it gives a progress bar), then reloaded the router's page saying the file was uploaded/installed.
You have to check the javascript/html in the update page yourself.
You can not get the full path of the file you want to upload via Javascript in Firefox3.X, only the filename is provided for privacy reasons. 
Some stupid javascript checks fails due to this.

Example:
FF2.X, IE : c:\users\secretusername\firmware.img
FF3: firmware.img

This is no bug and it's by design
Version: unspecified → 3.5 Branch
Check the javascript/html in the update page.
192.168.0.1 https://19216801help.com
Few months ago i also faced this same issue as i am unable to access file in D-Link router.If you are getting any kind of information related to router then i recommend you to read https://www.routertechnicalsupportnumbers.com/blog/how-to-fix-connection-failed-asus-error-651-in-windows-7-8-and-10/blog once to get proper guideline.
You need to log in before you can comment on or make changes to this bug.