Firefox 3.5(1) Unable to resolve addresses behind nat ("server not found"). Poss DNS issue caused by Scientific Atlanta (Cisco) router

RESOLVED DUPLICATE of bug 475603

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 475603
10 years ago
10 years ago

People

(Reporter: garognak, Unassigned)

Tracking

1.9.1 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Note: may be related to bug 502963 but that one has a different description.

Reproducable?: Depends on setup? Appears to only occur behind NAT/firewall.

(Behind a nat) Firefox (3.5 & 3.5.1) has problems finding pages the first time they are entered. Timeouts leads to server not found 
messages.

I have tested the following: Opened Firefox 3.5.1 and entered several web addresses (http://www.wired.com, http://www.imdb.com etc) 
and get errors on all or most. When doing the same in Opera, IE or firefox portable version 2 no such issues. 

Firefox 3.5(.1) has major problems finding sites the first time they are entered. After a few attempts to refresh they appear.
Seems to be a DNS issue. 

Have repeated the process many times (>10). Always problems with FF 3.5 (incl 3.5.1) never with FF 3.0X or FF 2 or any other browser.
Others are experiencing the same thing:

90 Posts long discussion on it here:

http://support.mozilla.com/tiki-view_forum_thread.php?locale=de&comments_parentId=381737&forumId=1

And some more here:

http://groups.google.com/group/mozilla.feedback.firefox/browse_thread/thread/fdfc1009c79ed1c2/7050a895659ebc62?lnk=raot

The gist from these discussions: 
It appears all users are behind a NAT or firewall.
Attempts to disable ipV6 have not made any difference.
The issue is not specific to any one operating system.
All problems disappeared when someone replaced the 3.5X version with a 3.0X version.


Reproducible: Always

Steps to Reproduce:
1. Place yourself behind firewall/NAT
2.  Make a clean firefox install of version 3.5 or 3.51
3.  Restart computer. (perhaps not needed)
4. Try to get access to a web page that you have not visited before by entering its address and see if it resolves it correctly.

Actual Results:  
If your setup is like mine you get a "server not found" message.

Expected Results:  
Displayed the page entered.

Have tested with several different configs (incl completely clean install)
It makes no difference.
Reporter

Updated

10 years ago
Version: unspecified → 3.5 Branch
NAT doesn't matter for Gecko nor does the DNS server because Gecko just asks the OS for a DNS resolution (getbyhostname() )!
It's something in the network or the OS if the DNS resolution fails and can't be, by the logic, Geckos fault.
Necko doesn't know if your Network goes though NAT or not and it doesn't recognize any Firewalls (only that some blocked packets my not arrive).

What could matter is that if you have a broken DNS server or DNS forwarder in your OS that breaks with more DNS requests as usual due to DNS prefetching.
There is an invalid report about a broken cheap and broken local DNS router with a broken DNS forwarder.

You can disable DNS prefetching for a test if you create (!) a new boolean pref in about:config with network.dns.disablePrefetch=true
Reporter

Comment 2

10 years ago
If you read my comment I clearly stated that this only happens on FF 3.5X while 
every other browser (inc older firefoxes) works fine. This is a specific problem
with FF 3.5X which I can see on my other machines as well. So this cannot simply
be a network setup problem.

Although it could be the case that there is an issue with my FW the large 
number of other people (see links in the original bug posting) who are seeing 
the same thing would appear to disprove that.

I will make a new test with a fresh install later without DNS prefetching 
though it would appear that others have tried that without success.
>This is a specific problem with FF 3.5X which I can see on my other machines as >well. So this cannot simply be a network setup problem.

DNS prefetching is new and generates more DNS requests as usual and it's already confirmed that a DNS forwarder in a small DNS/wlan router shows a bug in under this conditions.

Which router are you using ?
Reporter

Comment 4

10 years ago
I'm currently using a Scientific Atalanta (Cisco) router that connects me to
my cable provider. I have confirmed that the problem does not affect me 
when connecting via another way (like my mobile broadband connection) so it 
is likely to be the culprit.

I Have made several tests with the boolean suggested and it appears to 
have resolved the issue. Thank you for a helpful response.

The problem is very annoying though and it's far from obvious how to 
resolve it. It could perhaps be a good idea to give the user some 
additional kind of hint of what the case might be in case of a 'server 
not found' message.
That looks like a dupe of bug 475603.
I'm unsure if we can or should do something about this.

This must be a bug in one open source DNS forwarding client if it affects several routers.

There are "funny" comments in the support thread like "affects IE8/nslookup" if I install Firefox3.5. The issue is not installing Firefox3.5, it's the use of Firefox3.5 which does DNS prefetching and that genererates many DNS requests in a short time which seem to break the DNS forworder in the router.
The OS caches DNS resolutions for a short time and in this case the "not found" answer. Doing a "ipconfig /flushdns" should fix it.

I'm unsure what to do about this, add a relnote ?
Try to slow down DNS requests ?
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: 3.5 Branch → 1.9.1 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475603
Thanks reporter for checking this. Have you had a change to contact Cisco and inform them about the problem?
Summary: Firefox 3.5(1) Unable to resolve addresses behind nat ("server not found"). Poss DNS issue → Firefox 3.5(1) Unable to resolve addresses behind nat ("server not found"). Poss DNS issue caused by Scientific Atlanta (Cisco) router
You need to log in before you can comment on or make changes to this bug.